Menu Bar

The Menu Bar of Ancestris gives you access to all available actions via 7 menus.

en-menubar.png

Logic of the menu organisation

To easily find the actions you are looking for, here is the organisation we chose for the menus.

File Menu

This menu regroups all the actions to handle genealogy files.

  • Create, open, close, save, import, merge, export, change its properties, add to favourites
  • Exit the application

Edit Menu

This menu regroups all the actions to make global changes to your genealogical data.

  • Undo / Redo
  • Cut / Copy / Paste
  • Find / Replace / Delete
  • Generate Sosa or D'Aboville numbering
  • Change ID numbers
  • Mark special individuals
  • See modifications history

View Menu

This menu regroups all the actions to access the genealogical views.

These views show specific aspects of your genealogy and some let you edit your genealogy as well (e.g. editors, dynamic tree).

Tools Menu

This menu regroups all the actions to explore, manipulate and analyse genealogical data.

  • Genealogical Search among Ancestris users,
  • Consult registers records and use them to enrich your genealogy
  • Miscellaneous utilities (date calculation, calculator)
  • Verify data (anomalies, duplicates)
  • Analyse data (common ancestors, lists and reports)
  • Publish locally on disk or on the Internet 
  • Print the active view

Window Menu

This menu regroups all the actions to handle Ancestris windows.

  • Access to special windows
  • Handling windows : open, close, float, dock, clone, set to full screen

Options Menu

This menu regroups the main actions to customize Ancestris.

  • Preferences
  • Save display settings
  • Configure tools bar
  • Update Ancestris
  • Manage Plugins

Help Menu

This menu regroups all the actions to get help and to help Ancestris.

  • All the documentation
  • Contact Ancestris support team
  • Make a donation
  • Ancestris website
  • About Ancestris

 

Using the menus

Like the menu bar in many software programs, each menu in the Ancestris menu bar can be opened in two ways.

  • or by clicking on it
  • or by typing the key combination: <Alt> + the underlined letter in the name of the corresponding menu. For example, to open the Tools menu, type <Alt>+t.

Each action of the menu has:

  • an icon illustrating the action, when this icon exists
  • the name of the action
  • a keyboard shortcut to launch this action without going through the menu, when it exists

Here is an example with the File menu

    en-File-menu.png

    Similarly, each action can be initiated in several ways:

    • either by clicking on it in the menu
    • or when the menu is opened by typing the key combination: <Alt> + the underlined letter in the action name
    • or when the menu is closed by typing the keyboard shortcut of the action (Ctrl-N or Ctrl-S in the example above)