Preferências (I)

É aqui que se definem a maior parte das suas preferências de utilização. 

pt_preferences_appearance.png

/!\ Imagens com textos em inglês - separador Keymap

Assim que o Ancestris estiver instalado, pode começar imediatamente a inserir os seus primeiros dados. No entanto, se se familiarizar com algumas das definições, poderá adaptar o Ancestris à sua forma de trabalhar e dar à sua genealogia o aspecto que deseja. As preferências estão acessíveis a partir de vários locais:

Descrição

Barra de selecção

A janela de preferências tem, ao cimo, uma barra de selecção da categoria de opções que se podem modificar.

pt_preferences_tool_bar.png

/!\ Imagens com textos em inglês - separador Keymap

Clicando num dos botões, verá o conteúdo detalhado das preferências que podem ser modificadas na categoria correspondente.

O campo à direita é um filtro que facilita a procura de um dos parâmetros. A saída deste filtro é obtida premindo a tecla Esc.

Encontrará abaixo a descrição de cada categoria. Em cada categoria, as diferentes opções são acompanhadas por uma dica de ajuda, sob a forma de balão emergente.

Botões

Na zona inferior, a janela apresenta um conjunto de botões:

pt_preferences_bottom_buttons.png

Botão Exportar...

Este botão copia as suas preferências para um ficheiro. Muito útil se tiver instalado o Ancestris em vários computadores. Poderá aplicar as suas preferências imediatamente, sem ter de reconfigurar tudo.

Botão Importar...

Este botão recupera as preferências a partir de um ficheiro. É o inverso da operação anterior.

Botão Aceitar

Este botão valida quaisquer alterações feitas na janela de Preferências e fecha-a.

Botão Aplicar

Este botão valida quaisquer alterações feitas na janela de Preferências, sem fechar a janela.

Botão Cancelar

Este botão fecha a janela sem validar quaisquer alterações nela introduzidas.

Aparência

Este separador permite modificar a aparência geral do Ancestris.

pt_preferences_appearance.png
/!\ Imagens com textos em inglês - separador Keymap

Idioma do ambiente

Selecciona o idioma utilizado pelo Ancestris para utilizar em todas as janelas.

Idioma de saída

Selecciona o idioma utilizado pelo Ancestris para mostrar mensagens.

Aparência

Selecciona o estilo de exibição da janela (também chamado de aparência e sensação). Para cada estilo seleccionado (Padrão, Nimbus, Metal, etc...), é mostrado um exemplo  à direita. No entanto, se for seleccionado um novo estilo, este só será activado depois de reiniciar o Ancestris.

Algumas destas aparências são extensões (InfoNode, JTattoo, etc.) que precisam de ser instaladas para as fazer aparecer e utilizar. Ver a função Extensões para mais detalhes.

Janela

Quando a caixa estiver marcada, o tamanho e localização das janelas abertas quando saiu do Ancestris serão restauradas na próxima vez que iniciar o Ancestris.

Tamanho da memória


Especifica o tamanho da memória a atribuir ao Ancestris para trabalhar. Se estiver a utilizar grandes ficheiros genealógicos, poderá ser mais confortável atribuir um número mais elevado de Gigabytes.

Dados

Este painel permite modificar os formatos e conteúdos daquilo que o utilizador deseja mostrar na sua genealogia. É composto por dois separadores.

Separador Dados gerais

pt_preferences_data_general.png

/!\ Imagens com textos em inglês - separador Keymap

Símbolos

Mostra os caracteres tipográficos escolhidos para simbolizar certos acontecimentos (Nascimento, Casamento, Profissão, etc.).

Textos

Define a largura dos textos em número de caracteres (notas, textos-fonte, etc.). Não se recomenda a alteração do valor pré-definido - 246.

Imagens

Define o tamanho máximo em kilobytes de imagens.

Indivíduos

Indica a ordem de apresentação do primeiro e último nome dos indivíduos.

Datas

Define um dos quatro modelos possíveis para a exibição de datas.

Baptismo

Utiliza a data de baptismo na ausência da data de nascimento dos indivíduos. Por exemplo:

  • para mostrar o indivíduo raiz na barra de título da árvore dinâmica;
  • ou para pessoas relacionadas (ex: marido), no editor Gedcom.

Aqui estão dois exemplos, o primeiro com a exibição da raiz na árvore, o segundo com a exibição do marido no editor Gedcom:

.

Sem a caixa marcada Com a caixa marcada
pt_preferences_data_general_birth.png

 

pt_preferences_data_general_no_birth.png

 

pt_preferences_data_general_birth_gedcom.png

 

pt_preferences_data_general_no_birth_gedcom.png

Separador Privacidade

pt_preferences_data_privacy.png

/!\ Imagens com textos em inglês - separador Keymap

O separador Privacidade indica as suas preferências para aceder aos seus dados partilhados com outros genealogistas, ou para publicação na Internet.

É assim que protege os seus dados confidenciais.

  • São considerados privados dispõe de três opções acumulativas:
    • Propriedades com a etiqueta permite-lhe designar etiquetas que não serão transmitidas a terceiros. Por pré-definição, o Ancestris propõe a etiqueta _PRIV;
    • Pessoas vivas... permitem ocultar os indivíduos vivos;
    • Eventos dos últimos xx anos permitem definir um intervalo em anos, a ser calculado a partir da data actual e durante o qual os diferentes eventos serão ocultados;
  • Contudo, nunca são considerados privados mostra a caixa Dados de indivíduos falecidos, que autoriza a divulgação deste tipo de informação;
  • Substituir dados por permite escolher uma cadeia alfanumérica para substituir os dados mascarados. São propostas as reticências (...) por pré-definição.

Ficheiros

Este separador permite pré-definir ficheiros e pastas, assim como outros parâmetros a eles referentes.
pt_preferences_files.png

/!\ Imagens com textos em inglês - separador Keymap

Ficheiros Gedcom e pastas habituais

O nome do ficheiro Gedcom a abrir por pré-definição é o que figura no comando Abrir <Ficheiro pré-definido> no menu Ficheiro.

Quando o Ancestris inicia, por pré-definição abre os ficheiros genealógicos que estavam abertos na altura do último fecho.

As duas caixas de verificação alteram este comportamento. 

O ficheiro Abrir sempre este ficheiro independentemente dos ficheiros abertos quando fechar o Ancestris força a abertura do ficheiro pré-definido no arranque.

A caixa Não abrir nenhum ficheiro no arranque obriga o Ancestris a não abrir qualquer ficheiro no arranque.

A Pasta destino dos relatórios é a pasta onde o Ancestris guardará relatórios sobre o funcionamento ou mau funcionamento dos ficheiros.

Ficheiro de diário e cópias de segurança

O Tamanho máximo do ficheiro de diário limita o tamanho do diário. Se o tamanho máximo for atingido, o diário não conserva as primeiras linhas.

O Nível de diário indica ao Ancestris o nível de detalhe da informação a recolher pelo diário. Quanto mais para o lado de "SEVERE", menos detalhada é, quanto mais se dirige a "ALL", mais detalhada é. Tenha cuidado, quanto mais detalhado for, mais lenta será a sua utilização, já que tudo o que acontece no programa será anotado.

Número de cópias de segurança pede ao Ancestris para guardar um dado número de cópias anteriores do ficheiro Gedcom, a cada segurança, para além da versão mais recente. O nome de cada ficheiro é idêntico ao nome do ficheiro principal, mais a data e hora da segurança. Por exemplo, se o número de cópias de segurança for 3, cada cópia de segurança (acção Gravar do menu Ficheiro, ou <Ctrl-S>) produzirá a supressão da segurança mais antiga e a conservação de quatro exemplares da genealogia actual: o ficheiro mais recente e as três seguranças precedentes.

Editar

Este separador permite-lhe definir certas preferências de escrita do ficheiro de genealogia ou da utilização dos editores.

7v1pt_preferences_edit.png

/!\ Imagens com textos em inglês - separador Keymap

Nomes

Estas opções dizem respeito aos nomes dos indivíduos.

Pôr apelidos em maiúsculas, converte um apelido em maiúsculas no momento da validação da entrada.

Atribuir por pré-definição o mesmo apelido à mulher, atribui sempre o mesmo apelido à mulher ao criar os pais.

Etiqueta usada para nome próprio permite especificar a etiqueta a utilizar no ficheiro Gedcom para recolher o nome próprio habitual. Esta é  por pré-definição a etiqueta NICK

    Locais

    Esta opção diz respeito aos critérios dos locais, ou jurisdições. Compreende dois itens.

    A colocação de espaços entre os critérios de locais mostra, para melhor legibilidade, um espaço após cada vírgula que separa os vários critérios de locais, uma vez que os locais na norma Gedcom não têm nenhum.

    A separação dos critérios de locais permite editar os diferentes critérios associados separadamente no editor Gedcom.

    Com a caixa desmarcada:

    pt_preferences_edit_join_places.png

    Com a caixa marcada:

    pt_preferences_edit_split_places.png

    Número de identificação

    Esta opção diz respeito ao número de identificação de cada entidade.

    Reutilizar números eliminados disponíveis obriga o programa a reutilizar os números anteriores disponíveis que foram abandonados devido a eliminação de entidades.

    Comprimento pré-definido da ID da entidade impõe um número de algarismos para os números de identificação.

    Codificação

    Esta opção especifica a codificação do ficheiro gravado em disco, ou seja, a tabela de caracteres utilizada.

    Codificação do ficheiro selecciona a tabela de caracteres. É recomendado codificar com a tabela UTF-8.

    Editor

    Estas opções dizem respeito ao comportamento dos editores.

    Editor pré-definido indica o nome do editor a utilizar quando é escolhida a acção Editar do menu contextual.

    Submeter alterações automaticamente significa que não precisa de clicar em Aceitar para validar uma alteração nos editores. No entanto, a acção Eliminar ainda está sujeita à sua confirmação.

    Número máximo de cancelamentos é o número de alterações que podem ser desfeitas usando a tecla Ctrl+Z ou o botão Desfazer no menu Editar na barra de ferramentas.

    Criar ambos os cônjuges automaticamente  ao criar um progenitor adiciona sistematicamente ambas as caixas dos pais ao criar a ascendência de um indivíduo.

    Detectar automaticamente duplicados sempre que modifica um indivíduo detecta indivíduos duplicados cada vez que se edita um indivíduo. Um indivíduo pode de facto tornar-se um duplicado quando altera a sua data de nascimento, nome, etc. sem que tenha sido um duplicado no momento da sua criação.
    Ao gravar as alterações a esse indivíduo, o Ancestris compara com os critérios definidos na ferramenta de união de duplicados para ver se existe um duplicado.
    Se um duplicado for encontrado mas não unido, será detectado em cada modificação de um dos indivíduos.

    Separador Extensões

    Este separador permite definir as preferências das ferramentas constantes nos separadores abaixo.

    pt_preferences_extensions.png

    /!\ Imagens com textos em inglês - separador Keymap

    As opções de personalização de cada separador são descritas na respectiva página da secção de personalização.

    Separador Proxy

    Este separador diz respeito à sua ligação à Internet, se ela se faz através de um servidor intermediário ou não.

    pt_preferences_general.png

    /!\ Imagens com textos em inglês - separador Keymap

    • Primeira opção: Sem proxy.

    • Segunda opção: Utilizar as definições de proxy do sistema com um botão Recarregar. Esta é a configuração pré-definida de auto-detecção.

    • Terceira opção: Definições manuais de proxy. Quando esta terceira opção é seleccionada, o Ancestris pede informações adicionais sobre o servidor e a porta a utilizar.

     

    O botão Testar ligação é utilizado para verificar se a ligação foi correctamente configurada.

    Separador Atalhos

    Este separador diz respeito aos atalhos de teclado do Ancestris.

    pt_preferences_shortcuts.png

    /!\ Imagens com textos em inglês - separador Keymap e alguns atalhos

    A lista pendente Perfil selecciona um dos perfis gravados. NetBeans é o perfil padrão.

    O botão Mostrar como HTML abre o seu navegador com a tabela de atalhos de teclado. Útil se os quiser imprimir.

    O botão Gerir perfis permite-lhe atribuir diferentes atalhos em diferentes perfis. A janela que se abre para gerir perfis contém vários botões.

    pt_preferences_shortcuts_manage_profiles.png

    • Duplicar cria uma cópia do perfil seleccionado;
    • Repor pré-definições restaura o conteúdo original do perfil seleccionado;
    • Eliminar elimina o perfil seleccionado;
    • Exportar copia o conteúdo do perfil seleccionado para um ficheiro xml;
    • Importar cria um novo perfil a partir de um ficheiro xml;
    • Fechar fecha a janela Gerir perfis;
    • Ajuda abre a ajuda relacionada com esta janela (botão actualmente indisponível)

    Procurar permite filtrar a lista de atalhos de acordo com a sua acção.

    Procurar atalhos permite-lhe filtrar a lista de atalhos de acordo com uma combinação de teclas utilizada.

    Lista de atalhos

    Cada linha representa a possível associação entre uma acção e um atalho.

    A coluna Acções lista as diferentes acções do Ancestris.

    A coluna Atalho mostra o atalho de teclado da acção quando existe um.

    À direita de cada célula, há um botão [...] que abre um menu contextual contendo as seguintes acções.

    • Modificar permite adicionar uma combinação de teclas ou modificar uma já definida;
    • Adicionar uma alternativa (que só está presente quando a célula está preenchida) permite adicionar outro atalho para a mesma acção;
    • Repor pré-definições restabelece o atalho definido quando o Ancestris foi instalado;
    • Eliminar elimina o atalho.

    A coluna Categoria indica a categoria a que o comando associado pertence.

    Separador Vários

    Este separador diz respeito à janela de saída. Veja o tópico Menu Janela -> Saída.

    pt_preferences_misc.png

    /!\ Imagens com textos em inglês - separador Keymap e separador Output

    Estas opções definem os formatos de visualização das mensagens enviadas ao utilizador pelo software (mensagens de erro, avisos, etc.). Entre outras coisas, permite-lhe escolher a categoria e tamanho da letra, bem como a sua cor, dependendo do tipo de mensagem enviada.

    A parte inferior do painel exemplifica as escolhas feitas.

    Exportar e importar as sua preferências

    Não se esqueça que se quiser ter as mesmas preferências do Ancestris em vários computadores, deve pensar em exportar a sua configuração e depois importá-la.

    É igualmente possível fazer uma cópia da pasta .ancestris.

    Um clique em Exportar e pode seleccionar as opções que deseja exportar.

    pt_preferences_export.png

    Indique em seguida o ficheiro onde gravar as opções seleccionadas. Trata-se de um ficheiro em formato ZIP.