Préférences

C'est ici que vous définissez la plupart de vos préférences d'utilisation.

Préférences_Apparence.png

Dès qu'Ancestris est installé, vous pouvez immédiatement saisir vos premières données.

Cependant, si vous vous familiarisez avec certains paramétrages, vous pourrez adapter Ancestris à votre façon de travailler et donner à votre généalogie l'apparence souhaitée.

Les Préférences sont accessibles à partir de plusieurs endroits.

Description

Barre de sélection

La fenêtre des Préférences présente au-dessus une barre de sélection de la catégorie de préférences que vous pouvez modifier.

Préférences_Barre_Sélection.png

Un clic sur l'un des boutons fait apparaître le contenu détaillé des préférences qu'il est possible de modifier dans la catégorie correspondante.

Le champ à droite est un filtre qui permet de retrouver plus facilement un paramètre. /!\ Bug : revoir fonctionnement.

La sortie de ce filtre est obtenue en tapant la touche Échap.

Vous trouverez plus bas la description de chacune des catégories.

Dans chaque catégorie, les différentes options sont accompagnées d'une aide sous forme d'info-bulle.

Boutons

Dans sa partie inférieure, la fenêtre Préférences présente une série de boutons.

Préférences_Boutons.png

Bouton Exporter...

Ce bouton copie vos préférences dans un fichier. Très utile si vous avez installé Ancestris sur plusieurs ordinateurs. Vous pourrez ainsi appliquer vos préférences sans tout reconfigurer.

Bouton Importer...

Ce bouton récupère les préférences à partir d'un fichier. C'est l'opération inverse de la précédente.

Bouton OK

Ce bouton valide les éventuelles modifications effectuées dans la fenêtre Préférences et de fermer celle-ci.

Bouton Appliquer

Ce bouton valide les éventuelles modifications effectuées dans la fenêtre Préférences, sans fermer la fenêtre.

Bouton Annuler

Ce bouton ferme la fenêtre sans valider les éventuelles modifications effectuées dans celle-ci.

 

Apparence

Ce volet vous permet de modifier l'apparence générale d'Ancestris.

Préférences_Apparence.png

Langue interface

Sélectionne la langue utilisée par Ancestris pour afficher toutes les fenêtres.

Langue de sortie

Sélectionne la langue utilisée par Ancestris pour afficher des messages.

Apparence

Sélectionne le style d'affichage des fenêtres (aussi appelé le look and feel).

À chaque style sélectionné (Standard, Nimbus, Métal, Motif...), un échantillon s'affiche à droite.

Cependant, si un nouveau style est finalement sélectionné, celui-ci ne sera véritablement activé qu'après avoir relancé Ancestris.

Certains de ces look and feel sont des extensions (InfoNode, JTattoo, etc.) qu'il convient d'installer pour les faire apparaître et les utiliser. Voir la fonction Extensions pour plus de détails.

Fenêtre

Lorsque la case est cochée, les dimensions et l'emplacement des fenêtres ouvertes au moment de quitter Ancestris seront restaurées à l'identique au prochain lancement.

Taille mémoire

Spécifie la taille mémoire à allouer à Ancestris pour fonctionner.

Si vous utilisez des fichiers généalogiques de taille importante, il peut être plus confortable d'allouer un nombre de Giga-octets plus élevé.

/!\ TODO :  à déplacer dans un autre volet.

Taille des caractères

Indiquer à Ancestris dans quelle taille afficher les caractères dans toute l'application. /!\ TODO En développment. Revoir libellé.

 

Données

Ce volet vous permet de modifier les formats et les contenus de ce que l'utilisateur souhaite afficher dans sa généalogie. Il comprend deux onglets.

Onglet Données générales

Préférences_Données.png

Symboles

Affiche les caractères typographiques retenus pour symboliser certains événements (Naissance, Mariage, Profession, etc.).

Textes

Définit la largeur des textes en nombre de caractères (notes, textes de source, etc.).

Il est déconseillé de modifier la valeur par défaut : 246.

Images

Définit la taille maximale en kilo-octets des images. /!\ TODO Vérifier l'utilité.

Individus

Indiquer l'ordre de présentation du nom et du prénom des individus.

Dates

Définit l'un des quatre modèles possibles d'affichage des dates.

Baptême

Utilise le baptême en l'absence de naissance dans l'affichage des date de naissance des personnes.

  • Par exemple pour l'affichage de la personne racine dans la barre de titre de l'arbre dynamique.
  • Ou pour les personnes liées (ex: mari), dans l'éditeur GEDCOM.

Voici deux exemples, le premier avec l'affichage de la racine dans l'arbre, l'autre avec l'affichage du mari dans l'éditeur Gedcom.

Sans la case cochée Avec la case cochée
options_bapteme_arbre_off.png

options_bapteme_arbre_on.png

 

options_bapteme_editeur_off.png

 

options_bapteme_editeur_on.png

 

Onglet Données privées

Préférences_Données_Privées.png

L'onglet Données privées indique vos préférences d'accès à vos données dans la perspective d'un partage de votre fichier avec d'autres généalogistes, ou d'une publication sur Internet.

Vous protégez ainsi les données confidentielles.

  • Sont considérées comme privées affiche trois options cumulables.
    • Les Entités/Propriétés contenant l'étiquette permet de désigner l'étiquette des données qui ne seront pas transmises aux tiers. Ancestris propose par défaut le tag _PRIV
    • Personnes vivantes permet de masquer les personnes vivantes
    • Les événements des xx dernières années permet de définir un intervalle en années, devant être calculé depuis la date courante, et au cours duquel les différents événements seront masqués
  • Cependant, ne seront pas considérées comme privées affiche la case à cocher Les informations des personnes décédées qui autorise la diffusion de ce type d'information.
  • Remplacer les données privées par permet de choisir un segment alphanumérique devant se substituer aux données masquées. Un trois-points (...) est proposé par défaut.

 

Fichiers

Ce volet vous permet de définir les fichiers et répertoires par défaut, et d'autres paramètres relatifs aux fichiers.
Préférences_Fichiers.png

Fichiers Gedcom et répertoires usuels

Le nom du fichier Gedcom à ouvrir par défaut est celui qui figure dans l'action Ouvrir <Fichier par défaut> du menu Fichier.

Quand Ancestris démarre, il ouvre par défaut les fichiers généalogiques qui étaient ouverts au moment de la dernière fermeture.

Les deux cases à cocher modifient ce comportement.

La case à cocher Toujours ouvrir ce fichier quels que soient les fichiers ouverts lors de la fermeture impose à Ancestris d'ouvrir le fichier par défaut au lancement.

La case à cocher N'ouvrir aucun fichier au démarrage impose à Ancestris de ne pas ouvrir de fichier au démarrage.

Le Répertoire de sortie des rapports est celui dans lequel Ancestris enregistrera les rapports sur le fonctionnement ou les dysfonctionnements des fichiers.

Fichier Log et sauvegardes

Taille maximale du fichier Log limite la taille du fichier log. Si la taille maximale est atteinte, le log ne conserve pas les premières lignes..

Niveau de log indique à Ancestris le niveau de détail des d'informations devant être recueillies par le fichier log. Plus c'est vers "SEVERE", moins c'est détaillé, plus c'est vers "ALL", plus c'est détaillé. Attention, plus c'est détaillé, plus cela ralentit votre utilisation puisque sera noté tout ce qui se passe dans le logiciel.

Nombre de sauvegardes demande à Ancestris de conserver un nombre de copies précédentes du fichier Gedcom, à chaque sauvegarde, pour des raisons de sécurité, en plus de la dernière version. Le nom de chaque fichier de sauvegarde est identique au nom du fichier principal, auquel s'ajoute la date et l'heure de l'enregistrement.

Par exemple, si le nombre de sauvegardes est 3, chaque enregistrement (action Enregistrer du menu Fichier, ou <Ctrl-S>) produira la suppression de la plus ancienne sauvegarde et la conservation de quatre exemplaires de la généalogie courante : le fichier le plus récent, plus les trois précédentes sauvegardes.

 

Éditions

Ce volet vous permet de définir certaines préférences d'écriture du fichier généalogique ou d'utilisation des éditeurs.

Préférences_Editions.png

Noms

Ces options concernent le nom des individus.

Force tous les patronymes en majuscule, convertit un patronyme en majuscules au moment de la validation de la saisie.

Attribuer par défaut le même patronyme à l'épouse, attribue par défaut le même patronyme à l'épouse lors de la création des parents.

Étiquette du prénom usuel vous permet de spécifier l'étiquette à utiliser dans le fichier Gedcom pour recueillir le prénom usuel. Il s'agit par défaut de l'étiquette NICK. /!\ TODO : pourquoi conserve-t-on un truc pareil

    Lieux

    Cette option concernent les critères de lieux, ou juridictions. Elle comprend deux items.

    Mettre des espaces entre les critères de lieux affiche, pour une meilleure visibilité, un espace après chaque virgule séparant les divers critères de lieux, puisque que le lieu dans la norme Gedcom n'en comporte pas.

    Séparer les critères de lieux permet d'éditer séparément les différents critères associés dans l'Éditeur Gedcom.

    Case décochée.

    Ancestris 0.8 - exp place - fr.png

    Case cochée.Ancestris 0.8 - exp place Disting- fr.png

    Numéro d'identification

    Cette option concerne le numéro ID de chaque entité.

    Remplir les numéros disponibles d'abord force le logiciel à utiliser les numéros antérieurs disponibles abandonnés suite à des suppressions d'entités.

    Longueur par défaut de l'ID de l'entité impose un nombre de chiffres aux numéros ID.

     

    Encodage

    Cette option spécifie l'encodage du fichier sauvegardé sur disque, c'est-à-dire la table de caractères utilisée.

    Format d'encodage sélectionne la table de caractères. Il est recommandé d'encoder avec la table  UTF-8.

    Indicateur d'encodage à sauvegarder : /!\  TODO : A supprimer. Cela doit toujours être sauvegardé.

     

    Éditeur

    Ces options concernent le comportement des éditeurs.

    Éditeur par défaut indique le nom de l'éditeur à utiliser lors de l'action du menu contextuel Éditer.

    Appliquer les modifications sans confirmation vous dispense de cliquer sur OK pour valider une modification dans les éditeurs. L'action de Supprimer reste toutefois soumise à confirmation de votre part.

    Nombre maximal d'annulations est le nombre de modifications qu'il est possible d'annuler via la touche Ctrl+Z ou le bouton Annuler de la Barre d'outils.

    Créer automatiquement les deux conjoints lors de la création d'une liaison parent-enfant ajoute systématiquement les deux emplacements des parents au moment de créer l'ascendance d'un individu.

    Détecter automatiquement les doublons d'individus détecte les doublons d'individus à chaque fois que vous modifiez un individu. Un individu peut en effet devenir un doublon au moment où vous changez sa date de naissance, son nom, etc. sans qu'il l'ait été au moment de sa création.
    Lors de la sauvegarde de vos modifications sur la personne, Ancestris vérifie avec les critères définis dans l'outil Fusion de doublon si un doublon existe.
    Si un doublon est trouvé mais non fusionné, il sera détecté à chaque modification de l'un des individus.

     

    Volet Extensions

    Ce volet vous permet de définir les préférences des outils correspondants aux onglets ci-dessous.

    Préférences_Extensions.png

    Les options de personnalisation de chaque onglet sont décrites dans la page des outils correspondants, dans la section personnalisation.

     

    Volet Proxy

    Ce volet concerne votre mode de connexion Internet, si elle se fait via un serveur intermédiaire ou non.

    Préférences_Proxy.png

    • Première option : Aucun proxy
    • Deuxième option : Utiliser les paramètres proxy système, accompagnée d'un bouton Recharger. C'est le réglage par défaut de détection automatique.
    • Troisième option : Paramètres proxy manuels. Lorsque cette troisième option est sélectionnée, Ancestris vous demande des informations complémentaires.

    Le bouton Tester la connexion permet de vérifier si la connexion a été correctement configurée.

     

    Volet Raccourcis

    Ce volet concerne les raccourcis clavier dans Ancestris.

    Préférences_Raccourcis.png

     

    Profil sélectionne l'un des profils enregistrés. NetBeans est le profil par défaut.

    Le bouton Afficher au format HTML ouvre votre navigateur avec le tableau des raccourcis clavier. Bien pratique si vous souhaitez les imprimer.

    Le bouton Gérer les profils permet d'affecter des raccourcis différents à des profils différents. La fenêtre qui s'ouvre pour gérer les profils contient plusieurs boutons.

    • Dupliquer crée une copie du profil sélectionné
    • Restaurer les valeurs par défaut rétablit le contenu originel du profil sélectionné
    • Supprimer supprime le profil sélectionné
    • Exporter copie le contenu du profil sélectionné dans un fichier xml
    • Importer crée un nouveau profil à partir d'un fichier xml
    • Fermer ferme la fenêtre Gérer les profils
    • Aide ouvre l'aide relative à cette fenêtre (bouton actuellement indisponible)

    Rechercher permet de filtrer la liste des raccourcis en fonction de leur action.

    Rechercher dans les raccourcis permet de filtrer la liste des raccourcis. en fonction d'une touche utilisée.

     

    Liste des raccourcis

    Chaque ligne représente l'association éventuelle entre une action et un raccourci.

    La colonne Actions liste les différentes action d'Ancestris.

    La colonne Raccourci indique le raccourci clavier de l'action lorsqu'il existe

    À droite de chaque cellule, figure un bouton [...] qui permet l'ouverture d'un menu contextuel contenant les actions suivantes.

    • Modifier permet d'ajouter une combinaison de touches ou d'en modifier une déjà définie
    • Ajouter une alternative (qui est présente seulement quand la cellule est renseignée) permet d'ajouter un autre raccourci à la même action
    • Réinitialiser les valeurs par défaut remet le raccourci défini lors de l'installation d'Ancestris
    • Effacer supprime le raccourci

    La colonne Catégorie indique la catégorie à laquelle appartient la commande associée.

     

    Volet Divers

    Ce volet concerne la fenêtre Sortie. Voir Menu Fenêtre/Sortie.

    Préférences_Divers.png

    Ces options définissent les formats d'affichage des messages envoyés à l'utilisateur par le logiciel (message d'erreur, avertissement, etc.).

    Il permet entre autres choses de choisir la catégorie et la taille de la police de caractères, ainsi que sa couleur, selon le type de message envoyé.

    La partie inférieure du panneau affiche un aperçu des choix retenus.

     

    Exporter et Importer vos Préférences

    N'oubliez pas que si vous voulez avoir les mêmes préférences Ancestris sur plusieurs ordinateurs, il faut que vous pensiez à faire un export de votre configuration puis un import.

    Il est également possible de faire une copie du répertoire .ancestris.

     

    Un clic sur le bouton exporter et vous sélectionnez les options que vous souhaitez exporter.

    Préférences_Exporter.png

    Vous indiquez ensuite le fichier dans lequel seront sauvegardées les options sélectionnées. Il s'agit d'un fichier au format ZIP.