Barre de menus

La barre de menus de la fenêtre principale d'Ancestris permet d'accéder à toutes les actions disponibles.

Menu_barre.png

Logique de rangement dans les menus

Afin de trouver plus facilement les actions que vous cherchez, voici la logique de rangement que nous avons choisie d'adopter pour les actions des menus d'Ancestris.

Menu Fichier

Regroupe toutes les actions liées à la manipulation des fichiers de généalogie.

  • Créer, ouvrir, fermer, enregistrer, importer, exporter, réunir, modifier ses propriétés, mettre en favoris
  • Quitter

Menu Édition

Regroupe toutes les actions d'assistance à la modification des données.

  • Annuler / Rétablir
  • Couper / Copier / Coller
  • Rechercher / Remplacer / Supprimer
  • Numéroter les individus
  • Archiver les modifications

Menu Vue

Regroupe toutes les actions liées à l'accès aux vues généalogiques, qui permettent de travailler les données généalogiques

  • Les éditeurs sont des vues et certaines vues permettent d'éditer. Les éditeurs sont donc rangés ici.

Menu Outils

Regroupe toutes les actions liées à l'exploitation des données généalogiques.

  • Rechercher des informations généalogiques, récupérer des données d'actes
  • Utilitaires divers (calcul de dates, calculette)
  • Contrôler les données (anomalies, doublons)
  • Analyser les données (ancêtres communs, listes et rapports)
  • Publier
  • Imprimer

Menu Fenêtre

Regroupe toutes les actions liées à la manipulation des fenêtres.

  • Accéder à des fenêtres particulières
  • Manipuler les fenêtres : Ouvrir, fermer, ancrer, cloner les fenêtres en général, plein écran

Menu Options

Regroupe toutes les actions liées à la personnalisation d'Ancestris.

    • Préférences
    • Configurer la barre d'outils
    • Mettre à jour Ancestris
    • Gérer les Extensions

Menu Aide

Regroupe toutes les actions liées à l'obtention d'aide et à la communauté Ancestris

 

Utilisation des menus

À l'instar de la barre de menus d'un grand nombre de logiciels, chaque menu de la barre de menus d'Ancestris peut être ouvert de deux façons.

  • soit en cliquant dessus
  • soit en tapant la combinaison de touches : <Alt> + la lettre soulignée dans le nom du menu correspondant. Par exemple, pour ouvrir le menu Outils, il faut taper <Alt>+t.

Chaque menu contient des actions. Une action comprend.

  • l'icône illustrant l'action, lorsque cette icône existe
  • l'intitulé de l'action
  • le raccourci clavier permettant de lancer cette action sans passer par le menu

Voici un exemple avec le menu Fichier

Menu_Fichier.png

De la même façon, chaque action peut être lancée de plusieurs façons.

  • soit en cliquant sur celle-ci dans le menu
  • soit quand le menu est ouvert en tapant la combinaison de touches : <Alt> + la lettre soulignée dans le nom de l'action
  • soit quand le menu est fermé en tapant le raccourci clavier de l'action (Ctrl-N ou Ctrl-S dans l'exemple)