Menu Fichier

Ce menu permet de gérer les fichiers généalogiques, les fichiers media et de quitter Ancestris.

Menu_Fichier.png

Chacune des actions est décrite ci-dessous.

Les actions qui nécessitent plus d'explications font l'objet d'une page dédiée que vous trouverez en cliquant dessus.

Créer une généalogie

Lance l'assistant qui permet de créer une généalogie à partir de zéro.

Ouvrir <Fichier par défaut> (voir Préférences)

Ouvre le fichier par défaut préalablement choisi par l'utilisateur dans les préférences, menu Outils/Préférences, onglet Fichiers.

Cette action n'est disponible que si le fichier par défaut a été défini.

Ouvrir une généalogie

Ouvre une généalogie existante, sous forme de fichier Gedcom.

Si le fichier Gedcom provient d'un autre logiciel, Ancestris le détectera et effectuera automatiquement une importation.

Importer

Ouvre un fichier provenant d'un autre logiciel de généalogie.

Menu_Fichier_Importer.png

Actuellement, seuls sont importables des fichiers au format Gedcom.

Cette action permet de choisir le logiciel d'origine au cas où l'ouverture simple de l'action Ouvrir une généalogie ne le détecterait pas correctement.

Réunir deux généalogies

Réunit deux généalogies en une seule, c'est-à-dire fait la somme de deux fichiers Gedcom sans gérer les doublons éventuels.


Propriétés

Ouvre l'assistant de modification des propriétés générales de votre généalogie : son auteur, son format de lieu, l'emplacement des médias, la norme Gedcom souhaitée, etc.

Cet assistant permet en particulier :

  • de reformater tous les lieux au bon nombre de juridictions.
  • de gérer tous les fichiers médias de la généalogie et de les rattacher en cas de déplacement des fichiers.
  • de changer de norme Gedcom de 5.5 à 5.5.1 et vice-versa

Cette action n'est disponible que si un fichier Gedcom est sélectionné.

Ajouter aux favoris

Ajoute le fichier Gedcom sélectionné aux favoris. /!\ TODO : fonction à améliorer

Un fichier Gedcom doit donc être ouvert.


Enregistrer

Sauvegarde le fichier Gedcom sélectionné.

Les autres fichiers Gedcom ouverts ne sont pas sauvegardés.

Par sécurité, Ancestris conserve un certain nombre de sauvegardes de secours : l'utilisateur peut fixer ce nombre dans le panneau Préférences Fichiers, nombre de sauvegardes.

Cette fonction n'est disponible que si le fichier Gedcom sélectionné a été modifié mais pas encore sauvegardé.

Enregistrer sous...

Sauvegarde tout ou partie du fichier sous un autre nom.

Permet en particulier d'extraire une branche ou une partie de sa généalogie pour la donner à un tiers sous forme d'un fichier Gedcom indépendant.

Exporter

Exporte une généalogie vers d'autres espaces de généalogie tels que Geneanet, Geneweb ou CousinsGenWeb.

Menu_Fichier_Exporter.png

Il est important de constater que comme Ancestris sauvegarde le contenu de votre généalogie directement sous format Gedcom, le fichier Gedcom Ancestris est directement exploitable pour tous les logiciels de généalogie du monde entier.

Néanmoins, ceux-ci n’interprètent pas tous la norme exactement de la même façon.

Et c'est donc pour être parfaitement bien utilisé par les 3 plateformes citées plus haut, que l'export transforme légèrement le fichier Ancestris.


Fermer

Ferme le fichier Gedcom en cours d'utilisation, sans toutefois quitter Ancestris.

Quitter

Quitte Ancestris.