Saisie d'actes et relevé

L'outil Saisie d'acte et relevé est destiné à développer votre généalogie à partir de saisies d'actes effectuées par vous même ou par d'autres.

Cet outil est très puissant et permet de saisir des actes lors de dépouillements des registres communaux ou notariaux, pour les récupérer ensuite dans votre généalogie par différence, ou pour les exporter pour en faire bénéficier les autres.

Il est conçu pour faciliter la saisie des actes et pour contrôler leur cohérence au fur et à mesure.

Cet outil n'est pas installé par défaut quand vous installez Ancestris. Pour l'installer, il faut aller dans le Menu Outils et sélectionner Gérer les extensions

Cet outil a été développé par Michel Pujol.

releve.png

Un dépouillement désigne un relevé par un individu isolé ou une association généalogique de tous les actes d'un registre paroissial ou d'état civil avec transcription plus ou moins complète et exhaustive des informations. Source : Wikipédia

Dans notre cas, on parlera de dépouillement aussi bien pour un registre complet ou pour seulement quelques actes, le principe restant le même.

Principe

Les dépouillements se font par commune, les actes sont donc enregistrés par commune dans un fichier.

Pour être exploité par d'autre, chaque fichier ne doit donc inclure que des actes d'une seule commune. Cela vient du fait que c'est un fichier au format texte simple où chaque ligne représente un acte précédé de l'adresse de la commune, qui est la même sur toute les lignes.

Les actes de la commune sont saisis un par un grâce à un éditeur qui est sur la partie droite de la fenêtre.

Les actes saisis se rangent dans des tables sur la partie gauche de la fenêtre, en fonction des types d'événements qu'ils transcrivent.

Depuis les tables des actes, il est possible ensuite de faire un glisser déposer des lignes une par une vers la vue Arbre Dynamique pour enrichir sa généalogie. Voir la page Relevé - Glisser-Déposer pour plus de détails.

 

Démo

Pour découvrir l'outil Saisie d'actes et relevé, il est plus simple d'utiliser l'exemple de relevés fourni, qui comprend une vingtaine d'actes des Bourbons.

Cliquez sur le bouton Fichier puis choisissez Relevé démo pour l'ouvrir.

Releve_menu_fichier_demo.png

Le fichier sera chargé, correspondant à la commune de Versailles, avec les actes en question.

C'est une copie du fichier Démo et il vous sera possible de le modifier si vous voulez vous entraîner.

Ouvrez également la généalogie des Bourbons. Vous pourrez alors expérimenter les indications et manipulations illustrées dans la documentation qui suit.

 

Description

Sur la partie gauche de la fenêtre se trouvent cinq tables d'actes où iront se ranger les données des actes saisis.

  • la table des naissances
  • la table des mariages
  • la table des décès
  • la table des actes divers tels que les publications de mariage, contrats de mariage, testaments, quittances, etc.
  • la table récapitulative de tous les actes, qui est la somme des quatre précédentes

Sur la partie droite, on trouve l'Éditeur d'actes qui permet de gérer les fichiers de relevé et de saisir les actes pour une commune donnée.

Pour commencer, vous pourrez remarquer que les parties Table des actes et Éditeur des actes fonctionnent ensemble.

  • quand une table est sélectionnée sur la partie gauche, l'Éditeur s'adapte au type d'acte à saisir
  • quand un acte est sélectionné dans une table, l'Éditeur affiche les données correspondantes

Ajustez les largeurs des colonnes des tables pour mieux voir. La barre de séparation entre les Tables et l'Éditeur est également ajustable.

Le bouton Fichier déroule un menu Fichier donnant accès à la gestion des fichiers d'actes et à d'autres outils.

 

Tables des actes

Les actes sont classés dans cinq tables : Naissances, Mariages, Décès, Divers et Tous (la table récapitulative des actes).

Chaque table est affichée dans un onglet. Pour voir le contenu d'une table, cliquer sur l'onglet correspondant.

Chaque ligne représente un acte. Chaque colonne représente une donnée de l'acte.

Les colonnes affichées diffèrent selon le type d'acte. Ici, c'est la table récapitulative de tous les actes qui est sélectionnée, et la colonne Type affiche donc le type de l'acte de chaque ligne.

releve_tables.png

Voir le détail d'un acte

Cliquez sur une ligne dans la table afin que le détail de l'acte s'affiche dans l'éditeur à droite de la table.

Dans cet exemple, c'est un décès qui est sélectionné donc l'éditeur s'est adapté pour saisir les données que l'on trouve en général sur les actes de décès.

Menu déroulant

Un clic droit n'importe où dans cette partie gauche de la fenêtre affiche un menu déroulant qui permet de manipuler et renuméroter les actes

releve_actes_menu_deroulant.png

L'utilisation de la case à cocher Surligner les relevés existants dans le Gedcom est décrite plus bas.

Liaison entre les tables d'actes et les autres fenêtres d'Ancestris

Pour les actes surlignés uniquement, il y a deux possibilités de synchronisation avec les autres fenêtres d'Ancestris.

  • Un simple clic sur l'acte d'un individu affiche l'individu dans les autres vues d'Ancestris
  • Un double-clic sur un acte permet de reconstruire l'arbre à partir de l'individu de l'acte comme racine

Tri des colonnes

Cliquez sur le titre de la colonne pour trier la table par ordre alphabétique ou par ordre de date suivant le type de donnée de la colonne.

Déplacement latéral des colonnes

Pour déplacer une colonne, cliquez sur le titre de la colonne et déplacez latéralement la souris en maintenant le bouton enfoncé.

 

Éditeur d'actes

L'Éditeur d'actes permet de gérer les fichiers de relevé et de saisir les actes pour une commune donnée.

releve_editeur.png

L'Éditeur d'actes est composé d'un titre indiquant le nom de la commune, d'un formulaire de saisie le tout surmonté d'une barre d'Outils, dont le Menu Fichier donne accès à la gestion des fichiers et permet d'accéder à des outils.

Le nom de la commune

releve_nom_de_la_commune.png

Ce titre indique le nom de la commune du registre en train d'être dépouillé. C'est son adresse.

Le bouton de droite permet de changer l'adresse.

releve_registre.png

Tous les actes saisis seront enregistrés dans un même fichier portant par défaut le nom de la commune.

Chaque ligne du fichier commencera par cette adresse.

Le formulaire de saisie des actes

Le formulaire de saisie s'adapte au type d'acte à saisir et correspond au type d'acte sélectionné dans la table sélectionnée

  • Il affiche un formulaire de naissance pour une naissance, un formulaire de mariage pour un mariage, un formulaire de décès pour un décès.
  • Il affiche un formulaire Divers pour les autres actes, ce qui permet de saisir tout type d'acte. Un menu déroulant au début du formulaire permet de donner un nom au type d'acte.

Chaque formulaire est découpé en section et chaque section porte un titre avec un bouton sur la gauche.

releve_section.png

  • Le titre de la section désigne le type d'intervenant que la section de saisie concerne
  • Le bouton à gauche du titre en haut permet d'ajouter ou retirer des lignes à saisir
    • Un bouton '--' indique que l'on ne peut que retirer des lignes
    • Un bouton "+" indique que l'on peut en ajouter
    • Un clic sur le bouton fait apparaître le menu déroulant des champs affichables. Il faut les cocher pour les afficher.
      Voici par exemple le menu déroulant des données saisissables pour l'enfant d'un acte de naissance (celles-ci sont toutes cochées par défaut)

releve_section_menu.png

Dans le formulaire, le champ en cours d'édition apparaît avec un fond de couleur bleue.

releve_saisie.png

Le formulaire bénéficie d'une aide à la saisie et de raccourcis clavier décrit plus bas.

La barre d'outils

releve_toolbar.png

La barre d'outils comprend les actions suivantes.

Bouton Fichier

Ce bouton ouvre le Menu Fichier qui permet de gérer les fichiers d'actes (1 seule commune par fichier), d'accéder à un outil de recadrage des photos d'actes, et de vérifier les données des actes saisis.

Bouton Options

Ce bouton ouvre les préférences d'Ancestris, au volet Extensions et à l'onglet Relevé. Cela permet de régler les Préférences générales des fonctionnalités de relevé, de la visionneuse des actes, et des modalités de copie des actes dans un fichier Gedcom.

Bouton Création d'acte

Ce bouton génère une nouvelle ligne d'acte dans la table des actes, prête à être saisie.

Sélectionnez d'abord l'onglet de la table des actes correspondant au type d'acte que vous allez saisir avant de le créer.

Bouton Suppression d'acte

Ce bouton supprime l'acte sélectionné dans la table des actes.

Bouton Éditeur volant

Ce bouton ouvre une fenêtre volante contenant un deuxième Éditeur d'actes combinable avec une visionneuse des photos des actes.

releve_visionneuse_mini.png

La taille de sa fenêtre est suffisamment réduite pour être placée à côté des photos des actes pour faire la saisie en masse.

Elle est solidaire de la fenêtre volante de l'Éditeur d'actes qui se situe à droite. La visionneuse affiche la liste des photos d'acte en colonne à gauche, et l'acte en cours de visualisation au milieu.

Cet Éditeur volant contient une barre d'outils légèrement différente de l'Éditeur d'actes principal.

releve_editeur2.png

Les flèches gauche et droite permettent de se déplacer dans les actes, et le bouton Photo permet d'afficher ou de masquer la visionneuse des photos des actes.

 

Menu Fichier

Ce menu permet d'ouvrir ou d'enregistrer les fichiers de relevés. Ces fichiers ne peuvent être ouverts avec le menu Fichier de la barre de Menu d'Ancestris. Ce menu est le suivant.

Releve_menu_fichier.png

Nouveau

Crée un nouveau fichier d'actes pour une autre commune.

Si des données étaient en cours de saisie, un message vous alerte pour sauvegarder ce que vous étiez en train de faire.

releve_alerte_nouveau.png

Si vous confirmez, la table des actes se vide et Ancestris attend que vous commenciez à créer un nouvel acte.
/!\ TODO : traduire les boutons.

Ouvrir

Ouvre un fichier d'actes préalablement sauvegardé par Ancestris ou venant d'autres sources.

  • Les différents formats de fichiers sont reconnus automatiquement (format Ancestris, format EGMT ou format NIMEGUE)
  • Si le chargement détecte des lignes ne respectant pas un format de fichier connu alors un message d'erreur est affiché en indiquant la liste des lignes erronées.

Enregistrer

Enregistre les données dans un fichier au format Ancestris. Si le relevé a déjà été enregistré une première fois, les données sont enregistrées dans le même fichier. Si c'est la première fois que le fichier est enregistré, un nom de fichier est d'abord demandé.

Enregistrer sous

Demande un nouveau nom de fichier et enregistre les données dans ce nouveau fichier au format Ancestris.

Fichier démo

Ouvre un fichier de démonstration des Bourbons et affiche ses actes.

Importer

Ajoute les données d'un autre fichier aux données déjà présentes. Cela permet de fusionner le fichier importé avec le fichier déjà ouvert.

Toutes les données en mémoire doivent concerner la même commune. Si des relevés du fichier importé concernent une commune différente, il est proposé, soit d'ignorer les relevés, soit de remplacer leur commune par la commune des données en mémoire.

Exporter

Exporte les données dans un fichier au format EGMT ou au format NIMEGUE.

releve_export.png

Il faut préciser,

  • le format choisi du fichier d'export
  • le type des relevés à exporter (Naissances , Mariages, Décès, Divers ou tous les relevés)
  • le nom du fichier d'export

Recadrage des photos

Permet de retailler les photos d'actes. Un clic sur le bouton affiche la fenêtre de recadrage des photos des actes, dans laquelle il est possible de retailler les photos des actes.

Statistiques

Affiche le nombre de relevés présents dans le fichier.

releve_stats.png

Table de vérification

Affiche une table avec toutes les données contenues dans le fichier pour vérification globale.

Il y a une possibilité de chercher un acte en particulier et un bouton pour appeler l'éditeur volant.

releve_verification.png

Utilisation

Méthode

L'outil Saisie d'Actes et relevé couvre plusieurs besoins.

Développer votre généalogie

  • A partir de photos d'actes que vous avez pu trouver ou vous procurer.
    • l'outil vous permet d'abord de saisir les actes simplement à partir des photos
    • puis ensuite de récupérer les données pour développer votre généalogie
  • A partir de fichiers de dépouillement faits par d'autres.
    • l'outil vous permet de récupérer les actes qui vous intéressent pour alimenter votre généalogie

Aider les autres à développer leur généalogie

  • Saisir des actes en masse à partir des registres ou de photos lors d'un dépouillement
  • Exporter ensuite le fichier pour en faire bénéficier les autres

Dans tous les cas, si vous disposez des photos des actes, vous pouvez choisir ou non de relier automatiquement les photos aux actes.

  • lors de la navigation dans les actes : cela permet qu'en passant d'un acte à l'autre, la photo correspondante s'affiche
  • lors de la consultation de votre généalogie depuis une vue d'Ancestris : la visualisation d'une source vous affiche l'acte d'origine utilisé lors du dépouillement

Méthode d'utilisation proposée

Le reste de la page est une description de l'utilisation des différentes fonctionnalités de l'outil Saisie d'Actes et relevé selon une méthode générique que vous adapterez.

  1. Partir du stock des photos brutes des actes d'origine, et les redécouper pour en extraire une photo par acte, que vous placerez dans des dossiers par commune, de photos officielles référencées par sa cote dans le registre et son numéro.
    • Ces photos peuvent en effet contenir plusieurs actes, souvent avec des écritures difficiles à lire. Pour en faciliter la lecture à terme, il est préférable de séparer les actes.
    • Cette étape peut se faire avec l'outil Recadrage des photos
    • Chaque photo pourra être enregistrée avec comme nom du fichier, la référence de sa cote dans le registre et un numéro.
  2. Partir des photos recadrées pour saisir les actes par commune, avec les bonnes cotes et les bons numéros de photo
    • Cette étape se fait avec la Visionneuse d'Actes. Quand vous serez plus familier avec la saisie, vous pourrez régler les options de saisie qui vous conviennent le mieux dans les Préférences
    • Pour assurer le lien entre l'acte et sa photo, il sera nécessaire au préalable de le préciser à Ancestris dans les Préférences et d'indiquer où se trouvent les photos officielles
    • Chaque commune saisie fera l'objet d'un fichier séparé, que vous placerez dans un dossier des relevés
    • Pour la partie saisie, l'Éditeur d'actes permet une grande efficacité d'utilisation grâce à des raccourcis clavier, des contrôles à la saisie, et une fonction d'auto-remplissage des informations en  train d'être saisies
  3. Déplacer les actes par commune et chronologiquement, depuis un relevé vers votre généalogie
  4. Exporter les relevés par commune et les envoyer aux personnes intéressées, le cas échéant.
    • Il existe plusieurs formats de fichiers officiels pour les dépouillements : le format NIMEGUE et le format EGMT
    • Ces formats et celui d'Ancestris sont décrits dans l'Annexe sur les Formats de fichier

 

Recadrer des photos d'actes

Cette fenêtre est différente de la visionneuse des actes, même si elle est très similaire. On y accède par le menu Fichier de l'Éditeur d'actes.

releve_recadrage.png

Le survol des boutons ou des champs donne une info-bulle permettant de savoir ce qu'ils font.

Le principe de cet outil est le suivant.

  • Vous choisissez un répertoire d'entrée où sont stockées vos photos brutes à l'aide du bouton de gauche, et celui où elles seront sauvegardées avec le bouton de droite
  • Vous choisissez le format des noms des photos quand elles sont sauvegardées dans les deux champs de droite (cote du registre et numéro de photo)
  • Vous naviguez dans les photos avec les flèches avant/arrière
  • Sur chaque photo, vous déplacez les bords du cadre rouge pour définir les lignes de découpe de la photo. Il garde une position fixe de photos en photos
  • Un double clic sur la photo effectue la découpe et passe à la photo suivante. Revenez sur la photo précédente avec la flèche si elle contenait d'autres actes à découper
  • Un clic droit de la souris permet de placer / enlever un réticule en plus, qui permet de déplacer la photo au moment de la découpe
    • Usage facultatif rendu plus compréhensible si vous calez la photo en haut à gauche pour voir ce que cela fait : la partie en haut à gauche du réticule disparaîtra, la photo se déplacera en haut à gauche, et ensuite la découpe se fera selon le cadre rouge
    • Cela permet d'avoir toutes les photos de la même taille, celle du cadre rouge

 

La visionneuse d'actes

La visionneuse des photos des actes permet de saisir les actes à partir de leur photo, et de maintenir le lien ensuite.

Il est ainsi ensuite possible d'afficher la photo d'un acte à partir de son acte sélectionné dans l'Éditeur.

La visionneuse s'ouvre depuis le bouton releve_bouton_visionneuse.png de la barre d'outil de l'Éditeur d'actes.

Saisir des actes

Pour saisir les actes, indiquez le répertoire des actes avec le bouton en haut à gauche, sélectionnez l'acte, et créez l'acte à saisir à droite, renseignez l'adresse de la commune. Après la première saisie, vous devriez avoir quelque chose comme ceci

0mYreleve_visionneuse.png

Les flèches servent à visualiser la photo précédente ou suivante.

La photo est déplaçable et zoomable avec la souris.

Le bouton Optimise permet de forcer le contraste d'une partie de la photo. Après un clic sur le bouton, sélectionnez une zone rectangulaire de la photo. Pour quitter l'optimisation, nouveau clic sur le bouton.

releve_visionneuse_optimise.png

Référez-vous ensuite à la description de l'éditeur et aux facilités d'édition pour saisir l'acte.

 

Visionner une photo d'acte à partir de l'acte

Pour visualiser la photo d'un acte .

  • Si vous êtes déjà dans la visionneuse, il suffit de sélectionner l'acte avec les flèches de navigation à droite au-dessus du formulaire de saisie ou d'ouvrir le panneau de la visionneuse si celui-ci est masqué. Si l'acte n'a pas de référence photo, l'image affichée reste inchangée
  • Si vous êtes dans l'éditeur principal d'actes et que la visionneuse est fermée, il suffit de l'ouvrir avec le bouton visionneuse

La correspondance automatique entre l'acte et la photo ne fonctionne qu'à 3 conditions.

  • l'acte doit indiquer la référence de la photo dans la ligne 'photo'. Cette référence peut être un numéro ou un texte alphanumérique qui doit se trouver de façon unique quelque part dans le nom du fichier de la photo, il n'a pas besoin d'être le nom complet de la photo. Si plusieurs photos portent cette référence, c'est la dernière qui s'affiche
  • dans les préférences d'Ancestris, il faut avoir coché la case 'Afficher la photo de l'acte dans l'éditeur volant' et avoir ajouté le dossier des photos dans la liste comme ceci

releve_visionneuse_options1.png

  • le dossier des photos sur le disque indiqué dans l'image ci-dessus, doit inclure un sous-dossier avec le nom de la commune du relevé, dans lequel ou en-dessous duquel doit se trouver la photo de l'acte.

Suggestions de rangement des dossiers contenant les photos des actes

Plusieurs organisations de dossiers sont possibles. La visionneuse a simplement besoin qu'il existe un dossier portant le nom de chaque commune quelque part dans l'arborescence

Exemple avec des sous-dossiers

par département, par commune, et par cote

Exemple avec des sous-dossiers

par commune

/mesdocuments/Genealogie/Actes
       /Yvelines  
          /Versailles  
             /5MI_123
                /DSC00117.jpg
                /DSC00118.jpg  
             /5MI_222
                /DSC00200.jpg
                /DSC00201.jpg  
             /photos_a_trier
                /DSC00251.jpg
                /DSC00252.jpg  
          /Saint-Germain-en-Laye  
             /5MI_333  
                /DSC00300.jpg
                /DSC00301.jpg
       /Essonne  
          /Palaiseau  
             /5MI_108  
                /SAM00400.jpg
                /SAM00401.jpg
/mesdocuments/Genealogie/Actes
       /Versailles  
          /DSC00117.jpg
          /DSC00118.jpg  
          /DSC00200.jpg
          /DSC00201.jpg  
          /photo_a _trier
             /DSC00251.jpg
             /DSC00252.jpg  
       /Saint-Germain-en-Laye  
          /DSC00300.jpg
          /DSC00301.jpg
       /Palaiseau  
          /SAM00400.jpg
          /SAM00401.jpg

 

Différentes manières de renseigner la commune, la cote et la photo

Exemple 1 : la rubrique Photo peut ne contenir que le numéro de la photo , c'est à dire les derniers chiffres du nom de la photo

  • Commune=Versailles
  • Cote=5MI_123
  • Photo=117

Remarque : Dans cet exemple la visionneuse recherche une photo dont le nom se termine par "117" dans le dossier "Versailles" dans le dossier "5MI_123" qui est un sous-dossier de "Versailles" et sous-dossier de /mesdocuments/Genealogie/Actes

Exemple 2 :

  • Commune=Versailles
  • Cote=5MI_123
  • Photo=DSC00117

Remarque : Dans cet exemple la visionneuse recherche la photo dont le nom contient "DSC00117" dans le dossier "5MI_123" qui est un sous-dossier de "Versailles" et sous-dossier de /mesdocuments/Genealogie/Actes

Exemple 3 : la cote est facultative.

  • Commune=Versailles
  • Cote=
  • Photo=DSC00200

Remarque : Dans cet exemple la visionneuse recherche une photo dont le nom contient "DSC00200" dans tout le dossier de la commune "Versailles".

Exemple 4 : la photo peut être dans un sous-dossier quelconque de la commune, par exemple le sous-dossier "photos_a_trier"

  • Commune=Versailles
  • Cote=2E_456
  • Photo=DSC00251

Remarque: Dans cet exemple la visionneuse recherche la photo d'abord dans le sous-dossier de la commune de Versailles contenant le nom de la cote 2E_456 . Si le dossier correspondant à cette cote n'existe pas, ou s'il ne contient pas la photo, elle recherche ensuite la photo dans les autres sous-dossiers de la commune.

 

Exemple 5 : la commune est obligatoire

  • Commune=
  • Cote=
  • Photo=DSC00117

Remarque: Dans cet exemple la visionneuse ne trouve pas la photo car le nom de la commune est obligatoire

Exemple 6

  • PLAC=Versailles,78,Yvelines,,,
  • SOUR:PAGE=5MI_123, DSC00117

Remarque : Dans cet exemple la visionneuse recherche la photo de l'acte dans le dossier "5MI_123" qui est un sous-dossier de "Versailles" et sous-dossier de /mesdocuments/Genealogie/Actes

Exemple 7 : la cote est facultative dans le tag SOUR:PAGE

  • PLAC=Versailles,78,Yvelines,,,
  • SOUR:PAGE=DSC00200

Remarque : Dans cet exemple la visionneuse recherche une photo dont le nom contient "DSC00200" dans tout le dossier de la commune "Versailles".

Exemple 8 : le tag SOUR:PAGE peut ne contenir que le numéro de la photo , c'est à dire les derniers chiffres du nom de la photo

  • PLAC=Versailles,78,Yvelines,,,
  • SOUR:PAGE=117

Remarque : Dans cet exemple la visionneuse recherche une photo dont le nom se termine par "117" dans le dossier "Versailles"

 

Facilités d'édition

Raccourcis clavier pour l'Éditeur

Toutes les commandes de l'éditeur sont accessibles avec la souris ou avec des touches "raccourci" du clavier. L'utilisation des touches de raccourci est facultative. Cependant elle permet une saisie en masse plus rapide, en évitant d'avoir à utiliser alternativement la souris et le clavier.

Les touches de déplacement
  • TAB (tabulation) pour passer au champ suivant
  • SHIFT-TAB pour passer au champ précédent
Les touches de raccourci pour créer ou supprimer un relevé
  • ALT-N pour créer un relevé de naissance
  • ALT-M pour créer un relevé de mariage
  • ALT-D pour créer un relevé de décès
  • ALT-V pour créer un relevé divers
  • ALT-S pour supprimer le relevé courant
Les touches de déplacement rapide
  • ALT-1 Date de l'événement
  • ALT-2 Individu ou intervenant N° 1
  • ALT-3 Père
  • ALT-4 Mère
  • ALT-5 Épouse ou intervenant N° 2
  • ALT-6 Père
  • ALT-7 Mère
  • ALT-8 Témoins
  • ALT-9 Commentaire général
Les touches d'aide à la saisie et la touche d'annulation
  • ALT-X : copie le nom de l'individu dans le champ du nom du père de l'individu
  • ALT-Y : copie le nom de l'épouse dans le champ du nom du père de l'épouse
  • ALT-B : copie la date de l'événement du relevé dans le champ de la date de naissance de l'individu
  • ALT-=: copie la valeur de même champ de l'enregistrement précédemment saisi. Ce raccourci est particulièrement utile quand les témoins sont les mêmes d'un acte à l'autre par exemple
  • ESC (Escape) : annule la saisie d'un champ tant que le champ est en cours de saisie et retrouve la valeur d'origine tant que la zone est en cours de saisie
  • ALT-Z : Annule les modifications faites précédemment après avoir quitté le champ. Attention : la touche CTRL-Z habituellement utilisée pour cela ne fonctionne pas ici
  • Espace : Taper un espace en fin de champ pour refuser les autres termes proposés par la fonction de complétion. Cet espace est ensuite supprimé automatiquement. Par exemple, s'il existe des prénoms composés commençant par le prénom que l'on est en train de saisir, il faut taper un espace supplémentaire en fin du premier prénom pour refuser les prénoms secondaires proposés par la complétion

 

Contrôles et mise en forme automatiques à la saisie

Alerte date de l'événement et nom (ou prénom) absent
Si la date et le nom ne sont pas renseignés, un message d'erreur est affiché avant de passer à un autre relevé. Il est conseillé de compléter la donnée manquante pour éviter d'enregistrer ces informations importantes.
Alerte sur doublon
S'il existe déjà un relevé avec la même date, le même nom et le même prénom, un message d'alerte est affiché pour signaler un doublon possible.

Cette fonction peut être désactivée dans le panneau de configuration.

Alerte nouveau nom
Si un nouveau nom est saisi, un message d'alerte est affiché pour demander confirmation de ce nouveau nom. Cette alerte permet en particulier d'éviter de saisir des orthographes différentes et involontaires des noms couramment utilisés. Cette fonction peut être désactivée dans le panneau de configuration.
Casse du nom
Le nom est converti en majuscules au fur et à mesure de la saisie.
Casse du prénom
La première lettre de chaque prénom est mise en majuscule au fur et à mesure de la saisie.
Casse de la profession
Le première lettre de la profession est mise en majuscule lors de la saisie.
Suppression des espaces superflues
Les espaces en début et en fin de champ sont systématiquement supprimées quand la saisie d'un champ est terminée.
Copie automatique du numéro de photo
Quand un nouveau relevé est créé, le numéro de photo est renseigné automatiquement par copie du numéro de photo du relevé précédemment créé.

Cette fonction peut être désactivée dans le panneau de configuration.

Astuce : Le numéro de photo peut être facilement incrémenté en cliquant sur les boutons qui apparaissent à droite du champ, ou en utilisant les touches de direction HAUT et BAS.

 

Complétion des noms, prénoms , professions et lieux

Au fur et à mesure de la frappe d'un nom, des noms sont proposés parmi ceux déjà existants dans le fichier de relevé. Lorsque le nom souhaité apparaît, appuyer sur la touche Tabulation pour interrompre la saisie en cours et passer à la saisie du champ suivant.

Cela évite d'avoir à saisir toutes les lettres d'un nom déjà connu.

Exclure des noms
Il est possible d'exclure des noms des propositions de complétions avec l'option Exclure des noms dans la fenêtre des Préférences.
Complétion avec le Gedcom courant

Il est possible d'ajouter les noms présents dans un fichier Gedcom à la liste des noms proposés par la fonction de complétion en activant l'option Complétion avec le Gedcom courant dans la fenêtre des Préférences.

Quand cette option est activée, l'aide à la saisie utilise les noms, prénoms et professions du fichier Gedcom courant pour compléter les mots au fur et à mesure de la saisie. Cette option est utile en particulier quand on commence un relevé et qu'il y a encore peu de termes disponibles pour la complétion de la saisie parmi les relevés eux-mêmes.

Quand cette option est désactivée, la complétion utilise seulement les mots présents dans les relevés déjà saisis.

Remarque : il est préférable de choisir un Gedcom contenant des données d'un lieu et d'une date proches des relevés à saisir pour que la complétion puisse proposer des données semblables à celles qui doivent être saisies.

 

Surligner les actes existants dans le Gedcom

Une fois que des actes ont été saisis dans des fichiers de relevé, nous allons les copier dans le fichier Gedcom. Mais avant cela, il va falloir savoir lesquels doivent être copiés.

  • Vous pouvez déjà avoir copié, vous-même, des actes dans votre généalogie
  • Ou des données similaires peuvent déjà se trouver à jour dans votre généalogie

Il est possible de voir quels actes ont des données similaires dans votre généalogie, c'est-à-dire dans le fichier Gedcom actuellement ouvert dans les autres vues d'Ancestris.

Pour cela, il faut les surligner en utilisant le menu déroulant de la table des actes.

Il faut décocher / recocher la case pour faire apparaître les nouveaux actes récemment passés dans le gedcom.

Les actes existant dans votre généalogie sont ceux en rouge dans la table.

  • Un acte correspond à un événement de votre généalogie si les deux événements sont de même nature, si les deux ont la même date, et si les deux individus comparés ont le même nom et le même prénom
  • Le lieu n'a pas besoin d'être renseigné ou identique pour signaler une correspondance
  • En cas de doublon d'individu, le premier trouvé sera celui comparé, l'autre sera ignoré

Si la case est cochée, le surlignage se met automatiquement à jour si vous ouvrez ou fermez un fichier Gedcom dans Ancestris.

Dans l'exemple ci-dessous, 5 actes sont déjà présents dans le fichier Gedcom actuellement ouvert.

releve_liens_gedcom.png

 

Glisser-déposer dans l'Arbre dynamique

Un fois les actes surlignés, il est plus facile de savoir lesquels et comment les intégrer dans votre généalogie.

Les informations d'un relevé peuvent être copiées dans l'arbre dynamique en utilisant la fonction Glisser-Déposer . Ainsi il n'est pas nécessaire de re-saisir toutes les informations du relevé avec un éditeur d'Ancestris pour les mettre dans la généalogie.

Pour copier, il faut avoir à la fois votre fichier Gedcom ouvert et votre relevé d'acte, côte-à-côte.

Prenez l'exemple fourni des Bourbons et placez l'arbre dynamique des Bourbons  à gauche, et le fichier Démo de l'outil Saisie d'Actes et relevé  à droite ouvert sur l'onglet 'Tous'.

Nous voyons que les actes en rouge sont déjà renseignés dans la généalogie Bourbons.

releve_copie.png

Copier un acte de naissance

Nous allons copier l'acte de naissance de Louis Joseph Xavier CAPET du 13 sep 1751, du relevé des naissances vers le mariage de ses parents dans l'arbre dynamique.

Il n'est pas déjà présent dans le Gedcom car il n'est pas surligné en rouge.

La photo de l'acte de naissance a été renseignée.

Procédez ainsi pour copie l'acte dans le Gedcom :

  • cliquez dans la table sur l'acte de naissance,
  • déplacez-le avec la souris en maintenant le bouton gauche enfoncé jusqu'au mariage du 9 février 1747 dans l'arbre et relâchez le bouton.
releve_copie_dnd.png

 

Après avoir relâché le bouton de la souris, une fenêtre de validation s'affiche. Il s'agit de fusionner intelligemment les données dans l'arbre. C'est donc à vous de faire les choix, mais ils sont proposés par Ancestris.

releve_copie_dnd_merge.png

Choix de l'option de fusion

  • Ancestris vous propose une option de fusion et vous permet de cocher une case pour les voir toutes
  • Plusieurs "boutons radio" vous permettent de sélectionner votre option de fusion
  • Un survol de l'option vous donne un résumé des correspondances et les entités qui seront modifiées

Choix des données à fusionner

  • Les données de l'acte sont à gauche
  • Les données du Gedcom sont à droite
  • Les données différentes sont dans les cases bleues
  • Seules les données cochées dans la colonne centrale seront copiées dans le Gedcom
  • Il est possible de décocher les données que l'on ne souhaite pas copier

Choix des identifiants

  • La colonne intitulée Identifiant précise les entités concernées par les modifications
  • Un clic sur un identifiant sélectionne l'entité
  • Un clic sur "Choisir une source" permet de choisir la source préalablement définie dans le Gedcom

Dans l'exemple, un nouvel individu va être créé en tant qu'enfant de la famille F9 .

Après avoir cliqué sur le bouton OK, le nouvel individu n°I306 est créé dans l'arbre :

releve_copie_dnd_merged.png

Voici le résultat des données créées pour le nouvel l'individu dans l'éditeur Gedcom.

La note est sélectionnée est l'on voit comment Ancestris l'a documentée.

La source a été ajoutée avec la référence de la photo dans la propriété PAGE. Si j'avais documenté la cote, elle apparaîtrait aussi dans la propriété PAGE, juste avant la référence de la photo.

releve_copie_dnd_result.png

Selon que l'acte est déposé sur un individu, une famille ou dans le vide de l'arbre dynamique, la règle de fusion change.
  • Si la cible est un individu
    • L'outil signale s'il existe un autre individu portant un même nom et une même date de naissance dans le GEDCOM pour éventuellement éviter de créer un doublon dans le GEDCOM
    • Par défaut, le relevé de naissance est appliqué à l'individu
  • Si la cible est une famille
    • L'outil signale s'il existe un autre individu portant un même nom et une même date de naissance dans le GEDCOM même dans une autre famille
    • Par défaut, le relevé de naissance est appliqué à l'enfant de la famille ayant le même nom, prénom et éventuellement la date de naissance la plus proche s'il y a des homonymes. Un nouvel enfant est créé s'il n'y a pas d'enfant correspondant
  • Si la cible n'est ni un individu ni une famille ( fond de l'arbre dynamique)
    • L'outil signale s'il existe un autre individu portant un même nom et une même date de naissance dans le GEDCOM
    • Par défaut, un nouvel individu est créé et le relevé de naissance lui est appliqué

 

Copier un acte de mariage

Essayons maintenant de copier un acte de mariage.

Faites un glisser-déposer du relevé de mariage du 16 mai 1770 de la table vers le mariage concerné dans l'arbre.

releve_copie_mariage.png

Au relâché de la souris apparaît la fenêtre déjà vue plus haut sur les choix à faire pour la fusion.

Si vous avez remarqué plus haut, l'acte était surligné donc les données étaient déjà en partie renseignées dans le Gedcom.

releve_copie_mariage_fusion.png

Choix de l'option de fusion

  • Ancestris vous propose le mariage F10 qui existe déjà mais vous pourriez cocher la case pour voir les 3 autres propositions

Choix des données à fusionner

  • Les données en rouge existent déjà dans le Gedcom
  • Les données en bleu n'existent pas ou sont différentes
  • Les données manquantes sont pré-cochées.
  • Il est possible de décocher les données que l'on ne souhaite pas copier
  • Nous remarquons que les données des parents de l'épouse sont toutes manquantes. Elles seront donc créées

Choix des identifiants

  • Les identifiants sont déjà presque tous renseignés
  • Concernant les parents de l'épouse François DE HASBOURG-LORRAINE et Marie-Thérèse DE BRUNSWICK-WOLFENBÜTTEL, ils seront  ajoutés dans l'arbre avec création d'une nouvelle famille et de deux nouveaux individus

Déduction des dates

  • Les dates de naissance et de décès des parents de l'épouse sont déduites des données saisies dans l'acte
  • Un survol des données de la colonne Acte affiche une info-bulle qui permet de comprendre comment ces dates sont déduites
  • La règle de calcul des dates est indiquée plus bas

 

 

Après un clic sur le bouton OK, les parents de l'épouse sont ajoutés dans l'arbre et le mariage F10 est mis à jour.

releve_copie_mariage_parents.png

releve_copie_mariage_resultat.png

Conseils d'utilisation et limitations

Ajout dans l'ordre chronologique

Il est préférable de copier les relevés dans l'ordre chronologique . Pour cela il vaut mieux utiliser l'onglet "TOUS" classé par date et ajouter les relevés du plus ancien au plus récent , plutôt que d'ajouter d'abord les relevés de naissance puis les mariages, puis les décès. Cela améliore les résultats de la recherche des individus correspondant aux relevés.

Glisser-déposer en dehors d'une entité de l'arbre

Il est possible de déposer un relevé n'importe où dans la fenêtre de l'arbre dynamique, en dehors d'une entité de l'arbre.

Dans ce cas l'outil cherche l'individu ou la famille qui correspond le mieux au relevé et affiche une liste de propositions classées par ordre décroissant de pertinence.

  • avantage : cela évite de rechercher au préalable dans l'arbre l'individu concerné par le relevé
  • inconvénient : l'outil peut ne trouver aucune proposition si une donnée du relevé est incompatible avec les individus de l'arbre, ou ,au contraire, l'outil peut trouver plusieurs dizaines de propositions si les données du relevé sont trop imprécises
Annuler un glisser-déposer

Pour annuler les modifications faites dans l'arbre après un Glisser-déposer, cliquer n'importe où dans l'arbre pour sélectionner le Gedcom et appuyer sur les touches CONTROL et Z ou appuyer sur le bouton Annuler annuler.png de la barre d'Outils générale d'Ancestris. Une seule annulation suffit à supprimer tous les individus créés et toutes les données qui ont été ajoutées par un Glisser-déposer.

Règles de calcul des dates

Les déductions de dates se font selon les règles suivantes qui ne sont pas paramétrables.

  • Age minimum de mariage : 18 ans
  • Age minimum de parent : 15 ans
  • Age maximum de parent : 60 ans
  • Age maximum d'un individu : 100 ans
  • Intervalle d'incertitude pour les dates approximatives (date EST, ABT, CALC) : +/- 5 ans

 

 

Visionner un acte à partir d'une vue d'Ancestris

Pour visionner un acte à partir d'une vue d'Ancestris, il faut déjà avoir copié l'acte dans votre fichier Gedcom, ce qu'on a fait au paragraphe sur la copie des actes. Voir la section correspondante pour ce faire.

Ensuite, reprenons l'individu créé plus haut par copie de l'acte de Naissance, depuis l'Éditeur Gedcom, et appelons le menu contextuel par clic-droit n'importe où sur les propriétés de l'individu. Voici le menu qui apparaît.

releve_gedcom_view_photo.png

Vous remarquez la dernière action du menu : "Photo de l'acte : naissance".

Un clic sur cette action fait afficher la visionneuse des actes, sur l'acte de naissance de l'individu que nous avions saisi et copié plus haut.

releve_gedcom_visionneuse.png

La correspondance automatique entre la vue Ancestris et la photo de l'acte ne fonctionne qu'à 3 conditions.

  • L'information dans le fichier Gedcom doit inclure l'événement de l'acte de la façon suivante
    • un événement du type de l'acte
    • un lieu où le nom de la commune est celui de l'acte. Un réglage existe à ce niveau dans les préférences Ancestris de l'outil Saisie d'Actes et relevé. C'est lors du glisser déposer qu'Ancestris les utilise pour s'assurer que la définition des juridictions est bien alignée avec les données de lieu des actes
    • une source doit être indiquée avec une sous-propriété PAGE, qui doit indiquer la cote et la référence de la photo, séparées par une virgule
  • dans les préférences d'Ancestris, il faut avoir coché la case 'Afficher le menu "Photo de l'acte" dans les vues et ajouter le dossier des photos dans la liste comme ceci

releve_visionneuse_options2.png

  • le dossier des photos sur le disque indiqué dans l'image ci-dessus, doit inclure un sous-dossier avec le nom de la commune du relevé, dans lequel ou en dessous duquel doit se trouver la photo de l'acte.

 

 

Personnalisation

La personnalisation de l'outil se fait au moyen du bouton Préférences de la barre d'Outils de l'Éditeur d'Actes (qui revient au même que de passer par de la barre d'Outils d'Ancestris, Préférences, volet Extensions, onglet Relevé).

Les options sont organisées en 3 sections et leurs rôles et fonctionnement a été vu plus haut.

  • Options de l'éditeur
  • Visionneuse des photos des actes
  • Options de copie des actes dans un Gedcom

releve_perso.png

Le B-A BA qui suit est très riche et très bien fait. Il détaille également les options ci-dessus.

 

B-A BA

Il existe un B-A-BA pédagogique sur les relevés au format PDF.

Il correspond à la version 9 d'Ancestris mais l'essentiel est encore d'actualité.

Il vous indique dans le détail comment créer et utiliser des relevés.

Vous pouvez le télécharger.