Saisie d'actes et relevé

L'outil Saisie d'acte et relevé est destiné à développer votre généalogie à partir de saisies d'actes effectuées par vous même ou par d'autres.

Cet outil est très puissant et permet de saisir des actes lors de dépouillements des registres communaux ou notariaux, pour les récupérer ensuite dans votre généalogie par différence, ou pour les exporter pour en faire bénéficier les autres.

Il est conçu pour faciliter la saisie des actes et pour contrôler leur cohérence au fur et à mesure.

Cet outil n'est pas installé par défaut quand vous installez Ancestris. Pour l'installer, il faut aller dans le Menu Outils et sélectionner Gérer les extensions

Cet outil a été développé par Michel Pujol.

releve.png

Un dépouillement désigne un relevé par un individu isolé ou une association généalogique de tous les actes d'un registre paroissial ou d'état civil avec transcription plus ou moins complète et exhaustive des informations. Source : Wikipédia

Dans notre cas, on parlera de dépouillement aussi bien pour un registre complet ou pour seulement quelques actes, le principe restant le même.

Principe

Les dépouillements se font par commune, les actes sont donc enregistrés par commune dans un fichier.

Pour être exploité par d'autre, chaque fichier ne doit donc inclure que des actes d'une seule commune. Cela vient du fait que c'est un fichier au format texte simple où chaque ligne représente un acte précédé de l'adresse de la commune, qui est la même sur toute les lignes.

Les actes de la commune sont saisis un par un grâce à un éditeur qui est sur la partie droite de la fenêtre.

Les actes saisis se rangent dans des tables sur la partie gauche de la fenêtre, en fonction des types d'événements qu'ils transcrivent.

Depuis les tables des actes, il est possible ensuite de faire un glisser déposer des lignes une par une vers la vue Arbre Dynamique pour enrichir sa généalogie. Voir la page Relevé - Glisser-Déposer pour plus de détails.

 

Démo

Pour découvrir l'outil Saisie d'actes et relevé, il est plus simple d'utiliser l'exemple de relevés fourni, qui comprend une vingtaine d'actes des Bourbons.

Cliquez sur le bouton Fichier puis choisissez Relevé démo pour l'ouvrir.

Releve_menu_fichier_demo.png

Le fichier sera chargé, correspondant à la commune de Versailles, avec les actes en question.

C'est une copie du fichier Démo et il vous sera possible de le modifier si vous voulez vous entraîner.

Ouvrez également la généalogie des Bourbons. Vous pourrez alors expérimenter les indications et manipulations illustrées dans la documentation qui suit.

 

Description

Sur la partie gauche de la fenêtre se trouvent cinq tables d'actes où iront se ranger les données des actes saisis.

  • la table des naissances
  • la table des mariages
  • la table des décès
  • la table des actes divers tels que les publications de mariage, contrats de mariage, testaments, quittances, etc.
  • la table récapitulative de tous les actes, qui est la somme des quatre précédentes

Sur la partie droite, on trouve l'Éditeur d'actes qui permet de gérer les fichiers de relevé et de saisir les actes pour une commune donnée.

Pour commencer, vous pourrez remarquer que les parties Table des actes et Éditeur des actes fonctionnent ensemble.

  • quand une table est sélectionnée sur la partie gauche, l'Éditeur s'adapte au type d'acte à saisir
  • quand un acte est sélectionné dans une table, l'Éditeur affiche les données correspondantes

Ajustez les largeurs des colonnes des tables pour mieux voir. La barre de séparation entre les Tables et l'Éditeur est également ajustable.

Le bouton Fichier déroule un menu Fichier donnant accès à la gestion des fichiers d'actes et à d'autres outils.

 

Tables des actes

Les actes sont classés dans cinq tables : Naissances, Mariages, Décès, Divers et Tous (la table récapitulative des actes).

Chaque table est affichée dans un onglet. Pour voir le contenu d'une table, cliquer sur l'onglet correspondant.

Chaque ligne représente un acte. Chaque colonne représente une donnée de l'acte.

Les colonnes affichées diffèrent selon le type d'acte. Ici, c'est la table récapitulative de tous les actes qui est sélectionnée, et la colonne Type affiche donc le type de l'acte de chaque ligne.

releve_tables.png

Voir le détail d'un acte

Cliquez sur une ligne dans la table afin que le détail de l'acte s'affiche dans l'éditeur à droite de la table.

Dans cet exemple, c'est un décès qui est sélectionné donc l'éditeur s'est adapté pour saisir les données que l'on trouve en général sur les actes de décès.

Menu déroulant

Un clic droit n'importe où dans cette partie gauche de la fenêtre affiche un menu déroulant qui permet de manipuler et renuméroter les actes

releve_actes_menu_deroulant.png

L'utilisation de la case à cocher Surligner les relevés existants dans le Gedcom est décrite plus bas.

Liaison entre les tables d'actes et les autres fenêtres d'Ancestris

Pour les actes surlignés uniquement, il y a deux possibilités de synchronisation avec les autres fenêtres d'Ancestris.

  • Un simple clic sur l'acte d'un individu affiche l'individu dans les autres vues d'Ancestris
  • Un double-clic sur un acte permet de reconstruire l'arbre à partir de l'individu de l'acte comme racine

Tri des colonnes

Cliquez sur le titre de la colonne pour trier la table par ordre alphabétique ou par ordre de date suivant le type de donnée de la colonne.

Déplacement latéral des colonnes

Pour déplacer une colonne, cliquez sur le titre de la colonne et déplacez latéralement la souris en maintenant le bouton enfoncé.

 

Éditeur d'actes

L'Éditeur d'actes permet de gérer les fichiers de relevé et de saisir les actes pour une commune donnée.

releve_editeur.png

L'Éditeur d'actes est composé d'un titre indiquant le nom de la commune, d'un formulaire de saisie le tout surmonté d'une barre d'Outils, dont le Menu Fichier donne accès à la gestion des fichiers et permet d'accéder à des outils.

Le nom de la commune

releve_nom_de_la_commune.png

Ce titre indique le nom de la commune du registre en train d'être dépouillé. C'est son adresse.

Le bouton de droite permet de changer l'adresse.

releve_registre.png

Tous les actes saisis seront enregistrés dans un même fichier portant par défaut le nom de la commune.

Chaque ligne du fichier commencera par cette adresse.

Le formulaire de saisie des actes

Le formulaire de saisie s'adapte au type d'acte à saisir et correspond au type d'acte sélectionné dans la table sélectionnée

  • Il affiche un formulaire de naissance pour une naissance, un formulaire de mariage pour un mariage, un formulaire de décès pour un décès.
  • Il affiche un formulaire Divers pour les autres actes, ce qui permet de saisir tout type d'acte. Un menu déroulant au début du formulaire permet de donner un nom au type d'acte.

Chaque formulaire est découpé en section et chaque section porte un titre avec un bouton sur la gauche.

releve_section.png

  • Le titre de la section désigne le type d'intervenant que la section de saisie concerne
  • Le bouton à gauche du titre en haut permet d'ajouter ou retirer des lignes à saisir
    • Un bouton '--' indique que l'on ne peut que retirer des lignes
    • Un bouton "+" indique que l'on peut en ajouter
    • Un clic sur le bouton fait apparaître le menu déroulant des champs affichables. Il faut les cocher pour les afficher.
      Voici par exemple le menu déroulant des données saisissables pour l'enfant d'un acte de naissance (celles-ci sont toutes cochées par défaut)

releve_section_menu.png

Dans le formulaire, le champ en cours d'édition apparaît avec un fond de couleur bleue.

releve_saisie.png

Le formulaire bénéficie d'une aide à la saisie et de raccourcis clavier décrit plus bas.

La barre d'outils

releve_toolbar.png

La barre d'outils comprend les actions suivantes.

Bouton Fichier

Ce bouton ouvre le Menu Fichier qui permet de gérer les fichiers d'actes (1 seule commune par fichier), d'accéder à un outil de recadrage des photos d'actes, et de vérifier les données des actes saisis.

Bouton Options

Ce bouton ouvre les préférences d'Ancestris, au volet Extensions et à l'onglet Relevé. Cela permet de régler les Préférences générales des fonctionnalités de relevé, de la visionneuse des actes, et des modalités de copie des actes dans un fichier Gedcom.

Bouton Création d'acte

Ce bouton génère une nouvelle ligne d'acte dans la table des actes, prête à être saisie.

Sélectionnez d'abord l'onglet de la table des actes correspondant au type d'acte que vous allez saisir avant de le créer.

Bouton Suppression d'acte

Ce bouton supprime l'acte sélectionné dans la table des actes.

Bouton Éditeur volant

Ce bouton ouvre une fenêtre volante contenant un deuxième Éditeur d'actes combinable avec une visionneuse des photos des actes.

releve_visionneuse_mini.png

La taille de sa fenêtre est suffisamment réduite pour être placée à côté des photos des actes pour faire la saisie en masse.

Elle est solidaire de la fenêtre volante de l'Éditeur d'actes qui se situe à droite. La visionneuse affiche la liste des photos d'acte en colonne à gauche, et l'acte en cours de visualisation au milieu.

Cet Éditeur volant contient une barre d'outils légèrement différente de l'Éditeur d'actes principal.

releve_editeur2.png

Les flèches gauche et droite permettent de se déplacer dans les actes, et le bouton Photo permet d'afficher ou de masquer la visionneuse des photos des actes.

 

Menu Fichier

Ce menu permet d'ouvrir ou d'enregistrer les fichiers de relevés. Ces fichiers ne peuvent être ouverts avec le menu Fichier de la barre de Menu d'Ancestris. Ce menu est le suivant.

Releve_menu_fichier.png

Nouveau

Crée un nouveau fichier d'actes pour une autre commune.

Si des données étaient en cours de saisie, un message vous alerte pour sauvegarder ce que vous étiez en train de faire.

releve_alerte_nouveau.png

Si vous confirmez, la table des actes se vide et Ancestris attend que vous commenciez à créer un nouvel acte.
/!\ TODO : traduire les boutons.

Ouvrir

Ouvre un fichier d'actes préalablement sauvegardé par Ancestris ou venant d'autres sources.

  • Les différents formats de fichiers sont reconnus automatiquement (format Ancestris, format EGMT ou format NIMEGUE)
  • Si le chargement détecte des lignes ne respectant pas un format de fichier connu alors un message d'erreur est affiché en indiquant la liste des lignes erronées.

Enregistrer

Enregistre les données dans un fichier au format Ancestris. Si le relevé a déjà été enregistré une première fois, les données sont enregistrées dans le même fichier. Si c'est la première fois que le fichier est enregistré, un nom de fichier est d'abord demandé.

Enregistrer sous

Demande un nouveau nom de fichier et enregistre les données dans ce nouveau fichier au format Ancestris.

Fichier démo

Ouvre un fichier de démonstration des Bourbons et affiche ses actes.

Importer

Ajoute les données d'un autre fichier aux données déjà présentes. Cela permet de fusionner le fichier importé avec le fichier déjà ouvert.

Toutes les données en mémoire doivent concerner la même commune. Si des relevés du fichier importé concernent une commune différente, il est proposé, soit d'ignorer les relevés, soit de remplacer leur commune par la commune des données en mémoire.

Exporter

Exporte les données dans un fichier au format EGMT ou au format NIMEGUE.

releve_export.png

Il faut préciser,

  • le format choisi du fichier d'export
  • le type des relevés à exporter (Naissances , Mariages, Décès, Divers ou tous les relevés)
  • le nom du fichier d'export

Recadrage des photos

Permet de retailler les photos d'actes. Un clic sur le bouton affiche la fenêtre de recadrage des photos des actes, dans laquelle il est possible de retailler les photos des actes.

Statistiques

Affiche le nombre de relevés présents dans le fichier.

releve_stats.png

Table de vérification

Affiche une table avec toutes les données contenues dans le fichier pour vérification globale.

Il y a une possibilité de chercher un acte en particulier et un bouton pour appeler l'éditeur volant.

releve_verification.png

Utilisation

Méthode

L'outil Saisie d'Actes et relevé couvre plusieurs besoins.

Développer votre généalogie

  • A partir de photos d'actes que vous avez pu trouver ou vous procurer.
    • l'outil vous permet d'abord de saisir les actes simplement à partir des photos
    • puis ensuite de récupérer les données pour développer votre généalogie
  • A partir de fichiers de dépouillement faits par d'autres.
    • l'outil vous permet de récupérer les actes qui vous intéressent pour alimenter votre généalogie

Aider les autres à développer leur généalogie

  • Saisir des actes en masse à partir des registres ou de photos lors d'un dépouillement
  • Exporter ensuite le fichier pour en faire bénéficier les autres

Dans tous les cas, si vous disposez des photos des actes, vous pouvez choisir ou non de relier automatiquement les photos aux actes.

  • lors de la navigation dans les actes : cela permet qu'en passant d'un acte à l'autre, la photo correspondante s'affiche
  • lors de la consultation de votre généalogie depuis une vue d'Ancestris : la visualisation d'une source vous affiche l'acte d'origine utilisé lors du dépouillement

Méthode d'utilisation proposée

Le reste de la page est une description de l'utilisation des différentes fonctionnalités de l'outil Saisie d'Actes et relevé selon une méthode générique que vous adapterez.

  1. Partir du stock des photos brutes des actes d'origine, et les redécouper pour en extraire une photo par acte, que vous placerez dans des dossiers par commune, de photos officielles référencées par sa cote dans le registre et son numéro.
    • Ces photos peuvent en effet contenir plusieurs actes, souvent avec des écritures difficiles à lire. Pour en faciliter la lecture à terme, il est préférable de séparer les actes.
    • Cette étape peut se faire avec l'outil Recadrage des photos
    • Chaque photo pourra être enregistrée avec comme nom du fichier, la référence de sa cote dans le registre et un numéro.
  2. Partir des photos recadrées pour saisir les actes par commune, avec les bonnes cotes et les bons numéros de photo
    • Cette étape se fait avec la Visionneuse d'Actes. Quand vous serez plus familier avec la saisie, vous pourrez régler les options de saisie qui vous conviennent le mieux dans les Préférences
    • Pour assurer le lien entre l'acte et sa photo, il sera nécessaire au préalable de le préciser à Ancestris dans les Préférences et d'indiquer où se trouvent les photos officielles
    • Chaque commune saisie fera l'objet d'un fichier séparé, que vous placerez dans un dossier des relevés
    • Pour la partie saisie, l'Éditeur d'actes permet une grande efficacité d'utilisation grâce à des raccourcis clavier, des contrôles à la saisie, et une fonction d'auto-remplissage des informations en  train d'être saisies
  3. Déplacer les actes par commune et chronologiquement, depuis un relevé vers votre généalogie
  4. Exporter les relevés par commune et les envoyer aux personnes intéressées, le cas échéant.
    • Il existe plusieurs formats de fichiers officiels pour les dépouillements : le format NIMEGUE et le format EGMT
    • Ces formats et celui d'Ancestris sont décrits dans l'Annexe sur les Formats de fichier

 

Recadrer des photos d'actes

Cette fenêtre est différente de la visionneuse des actes, même si elle est très similaire. On y accède par le menu Fichier de l'Éditeur d'actes.