Migrare la tua genealogia verso Ancestris

La migrazione deve essere aperta nel file di genealogia di Ancestris da un altro programma.

Le espressioni "Migrate to Ancestris" o "Importare un file genealogico in Ancestris" significano quasi la stessa cosa. La migrazione presuppone che questa importazione venga eseguita una sola volta per un utente. L'importazione è un'operazione che un utente dovrebbe ripetere più volte.

Una migrazione comporta due tipi di difficoltà.

  1. Abbandona il software originale e scopri Ancestris
  2. Apri il file Gedcom dal tuo precedente software di genealogia, con Ancestris ora, senza perdere dati quando passi dall'uno all'altro

Il primo punto pone alcuni problemi. Si tratta semplicemente di abituarsi ad Ancestris e alla sua interfaccia: “  Qual è il nome di tale comando?  ","  Dov'è?  ","  Qual è la procedura per fare una cosa del genere?  ", Eccetera. Fondamentalmente, è un po 'come quando cambi veicolo: ci vuole tempo per adattarsi, ma non c'è nulla di insormontabile.

Il secondo punto, d'altra parte, può essere molto più difficile da negoziare . Ancestris è lì per semplificare il tuo lavoro.

 

Informazioni generali sull'importazione

Hai già creato una genealogia con un altro software e hai appena fatto la scelta di utilizzare Ancestris? Buone notizie: il programma Ancestris è in grado di leggere qualsiasi file in formato testo la cui architettura è definita dallo standard Gedcom (standard internazionale per lo scambio di informazioni tra software di genealogia).

Tuttavia, molti programmi non rispettano scrupolosamente questo standard: questi ultimi utilizzano effettivamente vari assiemi e parametri ad essi specifici, con, di conseguenza, la perdita di parte delle informazioni durante lo scambio di dati tra genealogisti.

Ecco perché Ancestris ha scelto di essere Gedcom al 100%  !

Per importare una genealogia in Ancestris, due situazioni.

  • O il tuo software originale è in grado di esportare i tuoi dati in formato Gedcom: Ancestris li leggerà senza problemi
  • Il tuo software originale non è in grado di esportare i tuoi dati in formato Gedcom. È abbastanza raro, ma in questo caso Ancestris non sarà in grado di leggerli, poiché il formato dei dati del software di genealogia è proprietario e noto solo ai loro editori. Dovrai quindi reinserire tutti i tuoi dati in Ancestris. Ma questa volta non puoi più perderli

Nella prima situazione, poiché quasi tutto il software è conforme solo in parte allo standard Gedcom, il file originale è probabilmente imperfetto rispetto allo standard e i dati immessi nel software precedente potrebbero non essere trovati in il file Gedcom prodotto da questo stesso software. Ma una volta in questo Gedcom, Ancestris recupererà tutto.

È qui che inizierai ad apprezzare Ancestris.

  • Ancestris si impegna a leggere qualsiasi file Gedcom, anche se non è conforme
  • Sono stati creati strumenti specifici di Ancestris per consentire all'utente di correggere alcuni errori in altri software. Non saremo in grado di risolvere tutto, ma riuscirai già ad eliminare alcuni problemi

Poiché il formato del file da importare deve necessariamente corrispondere allo standard Gedcom, la migrazione avviene in due fasi.

  1. Export . Dal tuo software precedente, devi esportare i tuoi dati in un file in formato Gedcom, ovvero convertire il file originale in un file con l'estensione * .ged . Qualsiasi buon software consente questa operazione
  2. Import . Apri il tuo file di dati Gedcom in Ancestris. Ancestris rileverà automaticamente il software originale che ha creato questo file Gedcom e apporterà le correzioni corrispondenti

 

Processo di importazione

Nella visita guidata hai visto la genealogia borbonica, file bourbon.ged. Questo è un esempio di genealogia fornita con Ancestris. Lo chiuderemo e migreremo la tua genealogia. È solo per fare spazio perché potremmo lasciarlo aperto. Per chiudere il file bourbon.ged, fai clic sulla croce rossa nella barra dei menu.

Ora migrerai o importerai la tua genealogia.

Dalla finestra principale, fai clic su "Migra la tua genealogia su Ancestris" o dalla barra dei menu , fai clic sul pulsante "Apri genealogia".

Ancestris ti chiede quindi il nome del file Gedcom da importare. Sceglilo e fai clic su Apri.

Un primo messaggio informa che Ancestris ha rilevato un file Gedcom da un altro software. Nel messaggio seguente, Ancestris non ha riconosciuto il software, perché non conosco il tuo, ma Ancestris è in grado di riconoscere il seguente software, elencato in ordine alfabetico.

  • Ancestrologie
  • Family Tree Maker (FTM)
  • Genbox
  • Geneanet
  • Genetica
  • Gramps
  • heredis
  • Albero genealogico legacy
  • Albero genealogico Mac
  • La mia eredita
  • RootsTrust
  • Altri software ("sconosciuto, conversione minima")

Ancestris spiega cosa farà. Clicca su Converti.

Migrer1.png

A questo punto, il file esportato viene elaborato, secondo i passaggi seguenti. Ancestris ti dice semplicemente che il tuo file è stato trasformato e rinominato in modo da non perdere l'originale. Il file trasformato verrà quindi aperto in Ancestris.

Migrer2.png

Ecco fatto. Ancestris ti dà il risultato della conversione in un altro messaggio. Ti consente anche di vedere le modifiche apportate. Fai clic su Sì per vederli, altrimenti chiudi questo messaggio facendo clic su No.

Se successivamente si desidera visualizzare l'elenco di queste modifiche, è sufficiente aprire la finestra "Esci", tramite il menu Finestra / Esci.

Abbiamo elencato in fondo a questa pagina le principali anomalie riscontrate durante le migrazioni di determinati software. Fare riferimento al paragrafo corrispondente al proprio software per maggiori dettagli.

Migrer3.png

 

Controllo della migrazione

Una volta aperto Ancestris sul nuovo file convertito, eseguiremo ora controlli compresi quelli indicati nella parte inferiore del messaggio precedente, vale a dire:

  1. Tutti i miei dati originali sono stati trasferiti nel nuovo file?
  2. I file multimediali sono stati correttamente bloccati?
  3. Vi sono anomalie nei dati o nel formato rilevate da Ancestris che devo correggere?

Verifica dei dati trasferiti

Esistono due modi per perdere i dati nel trasferimento:

  1. I dati non sono stati trasferiti nel file Gedcom esportato dal tuo vecchio software,
  2. I dati sono stati trasferiti, ma non si trovano nella stessa posizione nel file Ancestris.

Solo questi due controlli possono essere eseguiti visivamente.

Il primo è quello di aprire il file Gedcom esportato prima della conversione da Ancestris, con un editor di testo. Esplora alcune entità e vedi se tutto è lì controllando visivamente con il tuo software originale.

Il secondo controllo è guardare il tuo nuovo file Ancestris usando l'editor Gedcom. Vai alle entità che probabilmente hanno informazioni molto ricche e controlla come sono organizzate. Gli stessi tipi di informazioni sono stati memorizzati negli stessi luoghi, questo ti darà un'indicazione delle conversioni effettuate. Utilizzare anche la finestra Output per fare ciò (menu Finestra / Output).

Verifica dei file multimediali

I nomi dei file multimediali utilizzati dalla tua genealogia sono indicati nelle righe del file Gedcom.

Se i collegamenti vengono interrotti dopo un cambio di directory o se l'esportazione ha cambiato la radice, il supporto potrebbe non essere più visualizzato in Ancestris. Un test rapido è vedere se la tua foto è visualizzata, nel caso ne avessi già una in precedenza.

In questo caso, o anche per un controllo esaustivo, Ancestris sarà in grado di dirti se tutti i media sono agganciati. Per fare ciò, vai al menu File / Proprietà e avvia la procedura guidata.

Vedi l'uso di questo strumento nella sezione corrispondente.

Verifica di anomalie

Anche dopo la conversione, i dati potrebbero non essere ancora conformi allo standard Gedcom. Questo può essere il caso in cui i dati sono mancanti o errati.

Poiché Ancestris non elimina nulla dal file originale, ma non completa i dati mancanti, la conformità allo standard Gedcom potrebbe rimanere imperfetta.

Inoltre, i dati genealogici stessi possono contenere incoerenze.

Questo controllo può essere effettuato dalla funzionalità del menu / Strumenti / Gedcom / Standard di verifica Gedcom e Anomalie.

Ogni anomalia è elencata e puoi correggerla. L'ideale è farlo con l'editor Gedcom perché è il più trasparente sulle informazioni contenute nel file Gedcom.

Vedi l'uso di questo strumento nella sezione corrispondente.

 

Modifiche o aggiunte di informazioni

Una volta importati e effettuati i controlli, la tua genealogia deve essere arricchita. Puoi aggiungere altre persone o modificare o aggiungere informazioni.

Per questo, semplicemente per iniziare, scegli un individuo senza genitori dal tuo albero genealogico facendo clic su di esso e vedi come creare genitori e fratelli e sorelle facendo riferimento alla pagina precedente " Crea la tua genealogia ".

 

 


Problemi identificati da altri utenti durante l'importazione

Poiché molti software non sono conformi allo standard Gedcom, è molto probabile che noterai alcuni problemi relativi alla migrazione del tuo file.

Per tutto il software riconosciuto da Ancestris, abbiamo già effettuato le conversioni appropriate e non dovresti incontrare alcuna difficoltà, a meno che non ci siano stati cambiamenti dal nostro lavoro.

Per gli altri, ti invitiamo a farcelo sapere. Le annoteremo di seguito a beneficio di altri utenti, in attesa di poter fare gli sviluppi di conversione corrispondenti, se possibile.

Possiamo solo parlare dei problemi che gli utenti hanno portato alla nostra attenzione. Aiuta a migliorare Ancestris avvisandoci attraverso l' elenco delle discussioni .

 

Migrazione da Genealogie.com

I file generati dal sito genealogia genealogy.com non contengono informazioni relative al fornitore di informazioni. Tale indicazione è obbligatoria per conformarsi alla norma.

Soluzione Ancestris : creare le informazioni andando su File / Proprietà e indicare l'autore.

 

Migrazione da LifeLines

Con l'impostazione predefinita, LifeLines non esporta informazioni relative al fornitore di informazioni. Tale indicazione è obbligatoria per conformarsi alla norma.

Soluzione Ancestris : creare le informazioni andando su File / Proprietà e indicare l'autore.

 

Migrazione da Family Tree Builder

Family Tree Builder (FTB) genera molti tag univoci e rende il file Gedcom meno leggibile.

Soluzione Ancestris: rimuovere le etichette non necessarie con Menu / Modifica / Elimina.