Barra de menus

A barra de menus da janela principal do Ancestris dá-nos acesso a todos os comandos disponíveis.

pt_Menu_barre.png

Lógica da disposição dos menus

Eis a disposição escolhida para facilmente encontrar os comandos/acções nos menus do Ancestris.

Menu Ficheiro

Agrupa todas as acções respeitantes a gerir ficheiros de genealogia.

  • Criar, abrir, fechar, gravar, importar, exportar, alterar propriedades, adicionar aos favoritos
  • Sair

Menu Editar

Agrupa todas as acções respeitantes a alterar dados.

  • Desfazer/Refazer
  • Cortar/Copiar/Colar
  • Localizar/Substituir/Eliminar
  • Gerar números Sosa
  • Ver histórico de alterações

Menu Ver

Agrupa todas as acções respeitantes a acesso a vistas da genealogia, o que nos permite trabalhar os dados.

  • Os editores são vistas e algumas vistas permitem a edição. Os editores são, por isso, colocados aqui.

Menu Ferramentas

Agrupa todas as acções respeitantes a exploração dos dados genealógicos.

  • Partilha de árvores, recuperar dados
  • Registos
  • Utilitários diversos (conversor de datas, calculadora)
  • Verificação de dados (anomalias, duplicados)
  • Análise de dados (antepassados comuns, listas e relatórios)
  • Publicação
  • Imprimir

Menu Janela

Agrupa todas as acções respeitantes a gestão de janelas.

  • Acesso a janelas especiais
  • Gerir janelas: abrir, fechar, ancorar, clonar, ecrã completo

Menu Opções

Agrupa todas as acções respeitantes a personalizar o Ancestris.

    • Preferências
    • Configurar janela
    • Actualizar o Ancestris
    • Gerir extensões

Menu Ajuda

Agrupa todas as acções respeitantes a documentação e como obter ajuda e sobre a comunidade Ancestris

Utilizar os menus

Tal como a barra de menus em muitos programas, cada menu da barra de menu Ancestris pode ser aberto de duas maneiras:

  • clicando-o;
  • digitando a combinação de teclas <Alt> + a letra sublinhada no nome do menu correspondente. Por exemplo, para abrir o menu Ferramentas, digite <Alt>+t.

Cada menu tem acções/comandos. Uma acção compreende:

  • o ícone que ilustra a acção, quando este ícone existe;
  • o nome da acção;
  • o atalho de teclado para executar a acção sem passar pelo menu.

Aqui está um exemplo para o menu Ficheiro:

pt_Menu_Fichier.png

    Do mesmo modo, cada acção pode ser iniciada de várias formas:

    • clicando-a no menu;
    • quando o menu está aberto, digitando a combinação de teclas: <Alt> + a letra sublinhada no nome da acção;
    • quando o menu está fechado, digitando o atalho de teclado da acção (Ctrl-N ou Ctrl-S no exemplo acima).

    Revision #4
    Created Sun, Jun 7, 2020 9:38 AM by pedro
    Updated Wed, Sep 23, 2020 2:59 AM by pedro