Conhecer os menus e janelas

Descrição de todos os menus, janelas, vistas, editores e ferramentas.

Janela principal

A janela principal do Ancestris é aquela que vê quando abre o programa.

Se não houver uma genealogia aberta, veremos unicamente a página de boas vindas, já discutida.

Se tivermos uma genealogia aberta, deveremos ver várias janelas abertas, sejam elas a configuração pré-definida, seja qualquer configuração que tenha escolhido e gravado anteriormente.

pt_Fenêtre-Principale.png

Esta janela tem um título, uma barra de menus, uma barra de ferramentas e um espaço de trabalho, que contém as diferentes vistas e editores das genealogias em que se encontra a trabalhar.

Título

Sem genealogia, a barra de título parece-se com isto:

pt_titre-sans.pngSe tiver uma genealogia aberta, o nome da genealogia é apenso ao título como prefixo:

pt_titre-avec.png

Se tiver várias genealogias abertas, o título indica a que estiver actualmente seleccionada.

Barra de menus

A barra de menus está logo abaixo da barra de título. Permite-nos aceder aos comandos disponíveis, agrupados em sub-menus.

pt_Menu_barre.png

Por favor, consulte a secção Barra de menus para mais informação.

Barra de ferramentas

A barra de ferramentas está logo abaixo da barra de menus. Contém os comandos mais utilizados, sob a forma de ícones.

Pode ser personalizada. Para tal, vá ao menu Opções/Barras de ferramentas/Personalizar. Pode arrastar os ícones para dentro/fora das barras.

pt_barreoutils.png

Por favor, consulte a secção Barra de ferramentas para mais informação.

Espaço de trabalho

O resto da janela principal é o seu espaço de trabalho. é a zona amarela da imagem abaixo. Está organizada em diferentes janelas, cada uma com uma função específica. Por exemplo:

Ykkpt_Fenêtre-Principale_Espace_Travail.png

Área de trabalho e janelas (V)

A nossa área de trabalho está dividida em grupos de janelas.

Grupos de janelas

No exemplo abaixo, temos quatro grupos de janelas:

pt_Fenêtre-Principale_groupes.png

Podemos ter tantos grupos quantos desejarmos.

A área ocupada por um grupo de janelas varia. De uma maneira geral, tocam um extremo da janela principal, mas é possível ter um grupo desanexado.

Cada grupo contém uma ou mais janelas, mas só é mostrada uma de cada vez.

Janela

Uma janela é uma vista ou uma ferramenta aplicada a uma genealogia. Noutros casos, aplica-se a várias ou a nenhuma genealogia.

Eis o editor Cygnus, por exemplo, que é uma vista da genealogia Kennedy via editor Cygnus.

pt_Fenêtre.png

Uma janela é identificada pelo pequeno separador contendo um ícone e o seu nome.

Diferentes janelas poderão ter diferentes formas windows, mas todas funcionam da mesma maneira (abrir, fechar, mover e redimensionar).

Mais, é possível personalizar alguns aspectos: aquelas a abrir no início do programa, posições e tamanhos.

Segue-se uma explicação básica sobre as janelas e como personalizá-las.

Separador

O separador é o título da janela. Contém um ícone representando a natureza da vista ou a ferramenta utilizada na janela, seguido do nome da genealogia visível na dita janela.

No caso duma janela respeitante a uma única genealogia, tal como na imagem acima:

pt_kennedy_cygnus_tab.png

Graças a este separador, reconhecemos o ícone do editor Cygnus e a genealogia pelo seu nome.

É o mesmo nome mostrado na barra de título.

Isto permite ter árvores genealógicas de diferentes genealogias em diferentes janelas lado a lado. Nesse caso, o ícone será o mesmo para  ambas as janelas, mas o nome será diferente.

Também podemos ter uma árvore dinâmica e uma vista geográfica da mesma genealogia em duas janelas diferentes. Neste caso, o nome será o mesmo, a diferença estará no ícone.

Exemplos :

pt_kennedy_cygnus_gedcom_tab.png

pt_kennedy_bourbon_cygnus_tab.png

pt_kennedy_cygnus_bourbon_gedcom_tab.png

O separador pode estar sozinho ou ter vizinhos.

Se estiver sozinho, significa que não há mais janelas no grupo.

Se tiver vizinhos, significa que as janelas correspondentes partilham o mesmo grupo e só aquela está a ocupar o espaço comum: a que tem o separador realçado. Para mudar de janela basta clicar no respectivo separador.

Aqui temos a árvore dinâmica dos Kennedy no mesmo espaço de trabalho da página de boas vindas. A árvore é a que está à vista e à frente da outra.

pt_welcome_kennedy_tree_tab.png

Note que a janela de boas vindas não mostra o nome da genealogia.

De facto, se a janela não disser respeito a nenhuma genealogia (e.g. Boas vindas, Conversor de datas, Calculadora), ou se disser respeito a várias (Investigação genealógica), o nome do separador é o nome da ferramenta.

Exemplo : pt_OngletRecherche.png 

À direita do nome há ainda uma pequena cruz (x). É utilizada para fechar a janela.

Se pairar o rato por cima da cruz, verá um balão com informação sobre como fechar janelas no mesmo grupo. Voltaremos a este assunto mais tarde.

pt_Fenêtre_info-bulle.png

O separador da janela é também uma espécie de puxador, que permite manipular a janela com o rato e movê-la para outro grupo de janelas. Esse grupo pode já existir ou ser criado pela deslocação.

Também se pode manipular as janelas através do menu da janela.

Janela ancorada ou livre

Uma janela pode ter dois estados diferentes: ancorada ou livre (flutuante).

Está ancorada quando anexada a uma área específica da janela principal.

Está livre quando é independente da janela principal. Pode ser colocada em qualquer lado no ecrã.

Utilize a acção correspondente a partir do menu para ancorar e libertar janelas.

Janela ocultada

O separador também pode assumir a forma de um botão. Isto significa que a janela está ocultada, uma espécie de gaveta fechada, num dos contorno da janela principal.

Para ocultar uma janela, arraste o seu separador para um dos contornos da janela principal, mesmo para além do contorno.

Uma vez ancorada ao contorno, a janela fica em posição aberta. Basta clicar no botão superior direito para fechar a gaveta. Esta é a janela da tabela de entidades.

pt_reduire.png

Após a redução, a tabela de entidades está agora ocultada:

pt_Onglet_Escamoté.png

Basta pairar com o rato sobre o botão ou clicá-lo para abrir/fechar a gaveta.

Este é o caso do Explorador Gedcom, ao cimo à esquerda do Ancestris, aqui visível aberto:

pt_escamote.png

Quando visível, pode ser temporariamente ocultada premindo Ctrl + 0 no teclado numérico.

Para ancorar uma janela ocultada, é necessário clicar no ponto negro no canto superior direito, que voltará a aparecer como o ícone inicial de minimização da janela, retornada ao estado inicial.

Eis um vídeo mostrando como ocultar uma janela:

/!\  Inserir vídeo

Redimensionar uma janela

Para redimensionar uma janela, simplesmente arrastamos os contornos ou os cantos dessa janela.

Se nenhum dos quatro lados da janela estiver visível, provavelmente a janela está em ecrã completo: para os voltar a ver, basta clicar no botão de restauro, ao cimo à direita.

Alterar o tamanho de uma janela altera também o tamanho de todo o grupo onde ela está inserida.

Mover uma janela

Para mover uma janela basta arrastar o seu separador: clique com o botão esquerdo no separador da janela desejada e mantenha o botão premido durante o movimento, largando o botão quando a janela estiver na posição desejada.

Durante o movimento, o Ancestris mostra um contorna avermelhado da futura forma e posição. A posição dependerá se a deslocação for para o centro de uma área ou para uma periferia.

  • Quando o separador está próximo de outros separadores, é movido para a nova posição no grupo actual ou num novo grupo.
  • Quando o separador está  na margem de um grupo de janelas, será criado um novo grupo, o separador será movido para esse grupo e a sua janela ocupará sozinha esse espaço.

Um exemplo abaixo com o editor Cygnus e a família Kennedy a ser movido: aparece uma miniatura da janela enquanto um contorno avermelhado indica o reposicionamento.

pt_Fenetre_déplacement.png

Após os seus reposicionamentos, se achar a disposição mais conveniente e a pretender preservar para quando reabrir o Ancestris, grave a sua escolha via menu Opções/Gravar definições de exibição.

Menu da janela

Este menu abre com um clique direito ao cimo de qualquer janela. Inclui diferentes acções, usadas para manipular a janela.

A lista de acções depende do sítio onde clicou, se foi no grupo ou no separador.

Exemplos de menus da janela

 

pt_Menu_groupe_fenêtres.png

pt_Menu_fenêtre.png pt_Menu_fenêtre_escamotée.png

Acções do grupo de janelas

(clique direito sobre o grupo)

Acções de janela

(clique direito sobre o separador)

Acções de janela ocultada

(clique direito sobre o botão/gaveta)

Impacto das acções nas janelas

Fechar a janela

Elimina a janela do grupo de janelas.

Para abrir a janela novamente, tem de passar pela barra de menu.

Tenha cuidado se tiver alterações não gravadas, elas serão perdidas. Se tiver validado as suas alterações sem as gravar, elas não se perderão.

Se a janela que fechar for a última a dizer respeito a uma determinada genealogia, a genealogia será fechada. Se alguma das alterações validadas não foi gravada, o Ancestris pedir-lhe-á que o faça.

Fechar o grupo e as suas janelas

Fecha todas as janelas do grupo. O grupo de janelas desaparece.

Os outros grupos de janelas ocuparão o lugar libertado pelo grupo fechado.

As mesmas considerações dadas para fechar uma janela também se aplicam aqui.

Fechar outras janelas

Só a janela seleccionada permanece no grupo.

As mesmas considerações dadas para fechar uma janela também se aplicam aqui.

Maximizar a janela (caixa para marcar/desmarcar)

Quando a caixa está marcada, mostra a janela (e o grupo de janelas em que se encontra) em ecrã inteiro.

A janela ocupa todo o ecrã, mas esconde o contorno.

Se desejar restaurar a vista inicial, basta desmarcar a caixa.

Janela flutuante

Liberta uma janela ancorada da janela principal do Ancestris. Torna-se então visível sem a janela principal ou flutua acima das outras janelas.

Libertar o grupo

Igual à janela única, mas aplicado a todo o grupo.

Ancorar janela

Envia uma janela flutuante para o seu grupo original.

Ancorar grupo de janelas

Igual à janela única, mas aplicado a todo o grupo.

Mover à esquerda

Move o separador da janela para a esquerda dentro do grupo. Basicamente, troca a posição dos separadores.

Mover à direita

Move o separador da janela para a direita dentro do grupo. Basicamente, troca a posição dos separadores.

Clonar

Duplica a janela dentro do grupo.

Criar novo grupo de separadores com a janela actual

Cria um novo grupo e coloca lá a janela.

Fechar grupo de separadores e mover a janelas para outro

Move todas as janelas do grupo para outro grupo de janelas existente e fecha o grupo.

Atenção, se esta acção for realizada no último grupo aberto, as janelas serão fechadas e aplicam-se as considerações indicadas para fechar uma janela.

Mover a janela

Uma vez clicada esta acção, permite-lhe mover um rectângulo vermelho com as teclas do cursor para onde a janela será movida.  Prima Enter para validar a escolha ou Esc para cancelar.

Mover o grupo

Uma vez clicada esta acção, permite-lhe mover um rectângulo vermelho com as teclas do cursor para onde o grupo de  janelas será movida.  Prima Enter para validar a escolha ou Esc para cancelar.

Redimensionar o grupo

Uma vez clicada esta acção, permite-lhe redimensionar o grupo com as setas do teclado. Prima Esc e Enter para sair deste modo.

Esta acção só está disponível para certos grupos (por exemplo: tabela de entidades). 

Janela transparente

Ao clicar nesta acção, é mostrada uma mensagem de informação sobre as teclas a utilizar para tornar transparente o painel da janela oculta. Estas são as teclas Ctrl + 0 do teclado numérico.

Esta acção só está disponível para uma janela oculta. 

Botões do grupo de janelas

À direita da barra de separadores há um conjunto de botões com dicas:  pt_Fenetre_Boutons_Groupe.png

Rolar os separadores à esquerda ou à direita

Representado por setas à esquerda e à direita, permite percorrer os separadores quando forem muitos e não for possível vê-los todos.

Mostrar lista dos separadores abertos

Representado por uma seta para baixo, mostra um pequeno menu com a lista de janelas do grupo, permitindo escolher directamente a janela a mostrar no grupo.

Maximizar ou restaurar a janela

Dependendo da situação do grupo, abre o grupo em ecrã completo ou restaura-o para a posição anterior.

Relação entre janelas

Um conjunto de janelas para cada genealogia

Quando se abre uma genealogia no Ancestris, provavelmente abrem-se várias janelas:

Se tivermos várias genealogias abertas simultaneamente, teremos também vários conjuntos destas janelas: um para cada genealogia.

Sincronizar janelas da mesma genealogia

As janelas da mesma genealogia estão ligadas entre si e o seu conteúdo é actualizado, acompanhando a selecção actual.

A cada segundo, no Ancestris uma entidade genealógica (um indivíduo, uma família, uma fonte, etc.) é o centro da acção. É a entidade seleccionada no espaço de trabalho.

Uma vez seleccionada uma entidade numa das janelas, as outras ajustam-se para mostrar a informação específica da vista para a entidade seleccionada.

Por exemplo, se seleccionar um indivíduo na árvore dinâmica, também o verá nos editores e na tabela de entidades.

Este comportamento de sincronização só ocorre quando a vista relevante contém a entidade seleccionada.

Contra-exemplo : a árvore dinâmica mostra apenas os ascendentes e descendentes de um determinado indivíduo raiz. Se, digamos na tabela de entidades, seleccionar um indivíduo que não seja ascendente nem descendente desse indivíduo raiz, o conteúdo da árvore dinâmica não se alterará.

Outro exemplo, se a entidade seleccionada na árvore dinâmica for um indivíduo e não uma família e a tabela de entidades estiver em modo de família, a tabela também não será actualizada.

Este comportamento de sincronização também não ocorre quando a entidade numa vista está "pregada".

É possível bloquear a sincronização entre janelas nalgumas delas (editor Cygnus, editor Gedcom, árvore dinâmica, por exemplo) clicando em pin_bouton.pngao cimo das vistas/editores.

Barra de menus

A barra de menus da janela principal do Ancestris dá-nos acesso a todos os comandos disponíveis.

pt_Menu_barre.png

Lógica da disposição dos menus

Eis a disposição escolhida para facilmente encontrar os comandos/acções nos menus do Ancestris.

Menu Ficheiro

Agrupa todas as acções respeitantes a gerir ficheiros de genealogia.

Menu Editar

Agrupa todas as acções respeitantes a alterar dados.

Menu Ver

Agrupa todas as acções respeitantes a acesso a vistas da genealogia, o que nos permite trabalhar os dados.

Menu Ferramentas

Agrupa todas as acções respeitantes a exploração dos dados genealógicos.

Menu Janela

Agrupa todas as acções respeitantes a gestão de janelas.

Menu Opções

Agrupa todas as acções respeitantes a personalizar o Ancestris.

Menu Ajuda

Agrupa todas as acções respeitantes a documentação e como obter ajuda e sobre a comunidade Ancestris

Utilizar os menus

Tal como a barra de menus em muitos programas, cada menu da barra de menu Ancestris pode ser aberto de duas maneiras:

Cada menu tem acções/comandos. Uma acção compreende:

Aqui está um exemplo para o menu Ficheiro:

pt_Menu_Fichier.png

Do mesmo modo, cada acção pode ser iniciada de várias formas:

Menu Ficheiro

Este menu permite gerar novas genealogias, alterar propriedades dos ficheiros, sair do Ancestris.

pt_Menu_Fichier.png

Cada uma das acções é descrita abaixo.

As acções que necessitem de mais explicações terão uma página dedicada, assinalada por uma hiperligação.

Criar uma genealogia

Inicia um assistente para ajudar a criar uma nova genealogia a partir do zero.

Abrir <ficheiro pré-definido> (veja as preferências)

Abrir o ficheiro pré-definido, previamente escolhido nas preferências, menu Opções/Preferências, separador Ficheiros.

Esta opção só está disponível quando há realmente um ficheiro pré-definido. Caso contrário, estará a cinzento.

Abrir uma genealogia

Abrir uma genealogia existente a partir de um ficheiro Gedcom.

Se o ficheiro tiver sido criado por outro programa, o Ancestris detecta-o e inicia o processo de importação.

Importar

Abrir um ficheiro criado por outro programa de genealogia.

pt_Menu_Fichier_Importer.png

Actualmente só se podem importar ficheiros Gedcom.

Estas acções permitem escolher o programa original, ao passo que uma simples operação de abertura pode não o detectar correctamente.

Unir genealogias

Unir duas genealogias, ou seja, somar dois ficheiros Gedcom diferentes sem gerar duplicados ocasionais.

Propriedades

Abre o assistente e edita as propriedades da genealogia: autor, formato dos locais, pastas multimédia, norma Gedcom preferida, etc.

Neste assistente pode:

Esta acção só está disponível se tiver um ficheiro Gedcom seleccionado.

Adicionar aos favoritos

Adicionar o ficheiro Gedcom seleccionado aos favoritos.

Tem de ter um ficheiro Gedcom aberto.

Gravar

Gravar o ficheiro Gedcom seleccionado.

Se existirem outros ficheiros Gedcom abertos, estes não serão gravados.

Como garantia contra a perda de dados, o Ancestris mantém uma série de seguranças: este número pode ser alterado em Opções -> Preferências -> Ficheiros -> Número de cópias de segurança.

Esta função só está disponível se o ficheiro seleccionado sofreu alterações e ainda não foi gravado.

Gravar como...

Gravar o ficheiro ou parte dele sob outro nome.

Particularmente, permite extrair um ramo, parte da genealogia, sob a forma de um ficheiro Gedcom independente.

Exportar

Exportar uma genealogia para outros espaços, como Geneanet, Geneweb ou CousinsGenWeb.

pt_Menu_Fichier_Exporter.png

É importante notar que, como o Ancestris guarda o conteúdo da sua genealogia directamente no formato Gedcom, o ficheiro Ancestris Gedcom é directamente utilizável por todos os programas de genealogia a nível mundial.

Contudo, nem todos eles implementam a norma exactamente da mesma forma.

Portanto, é para ser perfeitamente utilizado pelas 3 plataformas acima mencionadas, que a exportação transforma ligeiramente o ficheiro Ancestris.

Fechar

Fecha o ficheiro Gedcom em uso, sem sair do Ancestris.

Sair

Sai do Ancestris.

Menu Editar

Este menu mostra as acções utilizadas para modificar uma genealogia.

pt_Menu_Edition.png

Cada uma das acções é descrita abaixo.

As acções que necessitem de mais explicações terão uma página dedicada, assinalada por uma hiperligação.

Desfazer

Desfazer a última acção no ficheiro Gedcom seleccionado.

É possível desfazer até 10 alterações. Este parâmetro pode ser alterado em Opções/Preferências/Editar - Número máximo de cancelamentos.

A opção só está disponível se houver alterações por gravar.

Não é possível desfazer alterações gravadas, mas é sempre possível restaurar uma segurança!

Refazer

Refaz a última alteração desfeita no ficheiro Gedcom seleccionado.

É possível refazer todas as alterações desfeitas.

Esta opção só está disponível se houver pelo menos uma alteração desfeita.


Cortar

Elimina o texto seleccionado e coloca-o em memória.

O texto pode ser colado em qualquer outro lado.

Esta acção só está disponível para campos de texto.

Copiar

Copia o texto seleccionado e coloca-o em memória.

O texto pode ser colado em qualquer outro lado.

Esta acção só está disponível para campos de texto.

Colar

Cola o conteúdo da memória na posição do cursor num campo de texto.

Isto pode referir-se a conteúdo de qualquer outro programa, algo copiado da Internet, etc..

Esta acção só está disponível para campos de texto.

Localizar...

Abre um assistente para ajudar a localizar uma cadeia de caracteres, não importa se esteja no ficheiro genealógico ou numa localização específica, tal como: tipos de entidade, propriedades, etc..

Substituir...

Abre um assistente para ajudar, em combinação com a funcionalidade de localização acima, substituir uma cadeia de caracteres por outra no ficheiro de genealogia.

Eliminar...

Eliminar um tipo de dados globalmente, em toda a genealogia. Particularmente útil para eliminar dados em branco.

Numeração Sosa

Permite gerar numeração Sosa, d'Aboville ou Sosa d'Aboville para um dado indivíduo.

Histórico de modificações

Abre uma janela mostrando todas as alterações feitas a um ficheiro Gedcom.

Se necessário, pode limpar a lista clicando em pt_clean_history.png.

Menu Ver

Este menu dá acesso às diversas vistas e editores disponíveis para o ficheiro seleccionado.

pt_Menu_Vue.png

Cada uma das acções é descrita abaixo.

As acções que necessitem de mais explicações terão uma página dedicada, assinalada por uma hiperligação.

Estas acções só se aplicam ao ficheiro Gedcom seleccionado e só estarão disponíveis se houver um ficheiro aberto.

As descrições seguintes dizem respeito à genealogia do ficheiro Gedcom seleccionado.

Cartão de entidade

Mostra um separador com a informação principal relativa à entidade seleccionada (indivíduo, família, etc.).

Tabela de entidades

Lista de todas as entidades na genealogia (indivíduos, famílias, notas, etc.) com os seus respectivos campos (número de identificação, nome, apelido, etc.)

Árvore dinâmica

Representa os indivíduos e as suas famílias num formato de árvore com ascendentes e descendentes do indivíduo raiz.

Cronologia

Mostra uma  representação temporal de todos os indivíduos na árvore.

Mapa geográfico

Mostra um mapa com todos os indivíduos e eventos na genealogia assinalados.

Gráfico

Representação visual inovadora de todos os indivíduos na genealogia em forma de gráfico.

Editor Cygnus

Abre o editor Cygnus, um editor fácil de utilizar com foco nos indivíduos.

Editor Gedcom

Abre o editor Gedcom, desenhado especificamente para permitir a transparência total dos dados na sua genealogia.

Editor Aries

Abre o editor Aries, um editor ergonómico que permite todo o tipo de alterações aos dados.

Lista de locais

Permite geo-localizar, editar ou unir locais e os seus eventos associados, acedendo ao editor de locais.

Tabela de locais

Permite aceder a uma lista estruturada de locais. Dá igualmente acesso ao editor de locais.

Navegador simples

Uma forma simples de seleccionar indivíduos num nó familiar.

Navegador estendido

Uma forma de seleccionar indivíduos num nó familiar enquanto vê a sua informação e fotografia.

Procura avançada

Permite a realização de uma pesquisa multi-critério e a exploração dos resultados em múltiplas vistas.

Menu Ferramentas

Este menu dá acesso a todas as ferramentas disponíveis no Ancestris.

pt_Menu_Outils.png

Cada uma das acções é descrita abaixo.

As acções que necessitem de mais explicações terão uma página dedicada, assinalada por uma hiperligação.

Certas ferramentas só se aplicam ao ficheiro Gedcom seleccionado. Assim, não estarão disponíveis se não houver nenhum aberto.

Partilha de árvores

Procurar indivíduos em comum com outros utilizadores do Ancestris.

Registos

Permite inserir escrituras ou recuperar registos (nascimento, casamento, óbito, outros) e depois integrá-los na sua genealogia.

Conversor de datas

Mostra uma ferramenta de cálculo, especificamente desenhada para datas e calendários. Bastante útil quando precisamos de estimar datas de escrituras e actos já encontrados.

Calculadora

Mostra uma calculadora simples, evitando ter de esperar pelo carregamento de uma calculadora externa.

 

Validação de dados e formato Gedcom

Detecta incumprimentos da norma Gedcom e anomalias de consistência.

Unir duplicados

Identifica e une duplicados.

Antepassado comum

Identifica antepassados comuns a dois indivíduos na genealogia.

Relatórios rápidos

Executa os relatórios imediatamente.

pt_Menu_Outils_RapportsRapides.png

Lista rápida

Executa o relatório Lista rápida para o indivíduo seleccionado.

Grupos familiares

Executa o relatório Grupos familiares.

Parentes próximos

Executa o relatório Parentes próximos.

Listas e relatórios

Abre a janela Listas e relatórios, fornecendo acesso a um vasto conjunto de relatórios gráficos e de texto que o Ancestris pode executar no ficheiro de genealogia, excepto aqueles descritos acima.

Publicação

Publique a sua genealogia num ficheiro ou na Internet, estilo páginas Web. O Ancestris propõe duas variantes.

pt_Menu_Outils_Publication.png

Livro Web

Gera uma genealogia sob a forma de páginas web, localmente ou num servidor remoto.

Página Web

Gera uma página Web.

Imprimir a vista actual

Imprime a vista seleccionada. Abre uma janela de antevisão.

Menu Janela

Este menu dá acesso a certas janelas especiais e faz a gestão geral de janelas.

pt_Menu_Fenetre.png

Cada uma das acções é descrita abaixo.

As acções que necessitem de mais explicações terão uma página dedicada, assinalada por uma hiperligação.

Página de boas vindas

Abre a página de boas vindas com as acções mais comuns mostradas amigavelmente.

Explorador Gedcom

Abre o explorador Gedcom, onde se pode ver uma árvore com a lista de todas as entidades presentes nas genealogias abertas.

Documento

Abre a janela Documento, que contém o resultado do último relatório.

Favoritos

Abre a lista de favoritos, um conjunto de ficheiros e pastas que foram seleccionados em Ficheiro/Adicionar aos favoritos.

Saída

Abre a janela Saída, que contém o resultado de comandos internos do Ancestris.

Por exemplo, a saída de uma importação é a lista das alterações efectuadas ao ficheiro original.

Configurar janela

Configurar a janela actual com o já mencionado sub-menu que obtemos clicando com o botão direito do rato no topo da janela. Veja Área de trabalho e janelas para obter mais informação.

pt_Menu_Fenetre_Configurer.png

Fechar janela

Fecha a janela activa.

Fechar todas as janelas

Fecha todas as janelas na área de trabalho activa, que é a que contém a janela activa.

Todas as janelas...

Abre o painel Janelas, o conjunto completo de todas as janelas abertas no Ancestris.

Isto permite activar qualquer janela a partir do seu nome.

pt_Menu_Fenetres_Toutes.png

A lista de janelas abertas está à esquerda.

A janela seleccionada está realçada e por baixo vemos uma descrição do seu conteúdo.

É possível seleccionar várias janelas:

Logo abaixo dos botões, pode escolher a ordem por que as janelas são mostradas.

Há outra forma de mudar directamente para outra janela. Prima Ctrl+Tab, mantenha Ctrl premida e use Tab ou Shift+Tab para escolher a janela na lista.

Isto abre uma mini-janela com a lista de janelas abertas:

pt_Liste_Fenêtres.png

As janelas ocultadas são as últimas na lista e estão à direita. A linha inferior mostra a descrição da janela, provavelmente truncada.

Janela activa em ecrã completo

Marque esta opção para pôr a janela activa em modo de ecrã completo ou desmarque-a para voltar ao estado original.

Ancestris em ecrã completo

Marque esta opção para pôr o Ancestris em modo de ecrã completo ou desmarque-a para voltar ao estado original.

Menu Opções

Este menu permite personalizar o Ancestris.

pt_Menu_Options.png

Cada uma das acções é descrita abaixo.

As acções que necessitem de mais explicações terão uma página dedicada, assinalada por uma hiperligação.

Preferências

Define as preferências do utilizador e personaliza o Ancestris. Por favor, consulte a página dedicada para mais informação.

Gravar definições de exibição

Isto permite recuperar a mesma disposição e tamanho das janelas quando reabrir o Ancestris. Consulte a explicação detalhada.

Configurar a barra de ferramentas

Marque e/ou desmarque as caixas para configurar a barra de ferramentas. Por favor, consulte também Barra de ferramentas para mais informação.

pt_Menu_Options_Toolbar.png

Há ainda mais três opções:

Actualizar o Ancestris

Obtém as últimas actualizações.

Gerir extensões

Instala ou desinstala funcionalidades extra do Ancestris.

Menu Ajuda

Este menu dá acesso a funções de ajuda e fornece informação sobre o Ancestris e a versão actual.

pt_Menu_Aide.png

Cada uma das acções é descrita abaixo.

As acções que necessitem de mais explicações terão uma página dedicada, assinalada por uma hiperligação.

Toda a documentação

Acede a este manual do utilizador.

Premir F1 faz o mesmo, não importa onde se encontre no programa.

Contactar a equipa do Ancestris

Envie-nos uma mensagem, a que é automaticamente uma mensagem com o diário do programa. Este diário ajuda-nos a diagnosticar mais rapidamente o seu problema.

Faça um donativo ao Ancestris

Abre uma janela com várias opções para doar ao Ancestris.

Website do Ancestris

Acede à página web do Ancestris.

Acerca do Ancestris

Abre uma janela com informação sobre a versão actual e as suas características.

Menu contextual

Há ainda outra forma de executar uma acção sem ir pela barra de menu, atalhos de teclado, ou barra de ferramentas. Que consiste em utilizar o menu contextual.

Um menu contextual é mostrado clicando com o botão direito do rato num objecto, normalmente uma entidade (indivíduo, família, fonte, etc.).

O menu contextual tem um título e uma lista de acções.

O título é o nome da entidade escolhida.

A lista de acções depende da entidade escolhida. É por isso que se designa por "contextual". Cada acção proposta aplica-se ao contexto do objecto escolhido.

Só algumas vistas oferecem o menu contextual.

São as seguintes:

Acções do menu contextual

Abaixo encontra-se uma descrição das possíveis acções.

Alterar a disposição de um indivíduo ou família

Permite configurar a quantidade e disposição da informação de uma entidade. Isto é conseguido através de um modelo, que pode ser alterado na janela aberta.

Cortar, copiar e colar

Permite cortar, copiar ou colar informação.

Adicionar directamente uma propriedade

Adicionar uma propriedade a uma entidade. Só verá as propriedades padrão permitidas na norma Gedcom.

Adicionar uma propriedade com um assistente...

Permite ver as propriedades que podem ser associadas à entidade seleccionada ou criar uma nova entidade.

Esta selecção é feita com um clique na coluna esquerda, o que mostra alguns detalhes sobre a utilização desta propriedade na coluna da direita.

Para criar uma nova propriedade, clique na opção final e insira o seu nome como mostrado.

Propagar as propriedades seleccionadas...

Permite associar as propriedades nas quais fez clique direito:

A caixa Propagar também o valor, quando marcada, automaticamente difunde não só a propriedade, mas também o seu valor.

Adicionar indivíduo/família

Permite adicionar um indivíduo ou uma família à entidade seleccionada. Acede a uma ou mais sub-acções:

 

Dependendo da entidade ou da propriedade em questão, nem todas as sub-acções estarão necessariamente presentes.

Adicionar multimédia, uma nota ou uma fonte

Permite associar uma entidade existente aquela onde clicou com o botão direito. Eis as sub-acções possíveis:

  1. Nota adiciona uma nota partilhada ou utiliza uma já existente;
  2. Elemento multimédia adiciona um elemento multimédia ou utiliza um já existente;
  3. Fonte adiciona uma fonte ou utiliza uma já existente;
  4. Investigador adiciona um investigador ou utiliza um já existente;

Criar uma entidade global

Permite adicionar uma ou mais entidades à sua genealogia, sem ligações aquela onde fez clique direito. Eis as sub-acções possíveis:

Gerir a numeração SOSA/d'Aboville

Permite gerar a numeração genealógica, começando no indivíduo no qual clicou com o botão direito.

O indivíduo seleccionado torna-se o número um da genealogia e é gerada nova numeração para todos os seus ascendentes e descendentes.

Substituir...

Disponível apenas para propriedades relacionadas com outra entidade.

Modificar o formato dos locais

Abre uma janela onde pode modificar o critério dos locais.

Encriptar as propriedades seleccionadas

Permite encriptar toda a informação da entidade.

NÃO perca a senha usada para encriptar a entidade, será impossível recuperar a informação sem ela.

Editar/Modificar

Abre o editor predefinido com a entidade seleccionada, faz alterações temporárias, não as grava.

Eliminar as propriedades seleccionadas...

Elimina as propriedades seleccionadas.

Esta acção é final. Verá uma janela para confirmar a eliminação.

Navegar para parentes

Um navegador de parentescos simples, permitindo ir directamente para um parente do indivíduo.

Marcador em árvore dinâmica

Cria um Marcador na árvore dinâmica para que se possa aceder ao indivíduo ou família directamente a partir do ícone Marcador na árvore dinâmica  bookmar_icon.png.

Tornar raiz

Reconstrói a árvore dinâmica para a entidade na qual clicou com o botão direito.

Executar um relatório

Permite executar qualquer um dos possíveis relatórios para a entidade seleccionada.

Escolher como família preferencial na árvore dinâmica

Permite escolher a família preferida e o cônjuge a mostrar na árvore dinâmica.

Trocar cônjuges

Se, por engano, os cônjuges foram inseridos ao contrário, utilize esta opção para corrigir.

Fotografia do registo: nascimento | casamento | óbito | mista

Permite mostrar, na visualizador de registos, a fotografia do acto correspondente ao nome do evento, numa entrada que tenha uma fotografia de uma declaração do acto.

Esta acção só aparece se a ferramenta Registos estiver instalada e não necessariamente aberta.

Menu Arrastar & Largar (I)

O menu Arrastar & Largar é uma forma de copiar ou unir entidades dentro da mesma genealogia ou entre genealogias.

A maioria destas acções são adicionais às que se podem encontrar na barra de menus, atalhos de teclado, barra de ferramentas e menu contextual.

Acede ao menu Arrastar & Largar clicando numa entidade (indivíduo, família, fonte, etc.) e arrastando-a para outra.

en-Drag-n-Drop-different.png

en-Drag-n-Drop-same.png

 

Menu Arrastar & Largar entre diferentes genealogias, de um indivíduo para outro indivíduo Menu Arrastar & Largar dentro da mesma genealogia, de um indivíduo para outro indivíduo

/!\ Imagens não traduzidas

Descrição

O menu Arrastar & Largar tem um título, uma descrição e uma lista de itens de acção.

A descrição indica o que foi o movimento de arrastar e largar:

A lista de itens de acção depende do movimento que efectuou e se as genealogias são diferentes ou não.

Os exemplos acima mostram itens de acção que estão geralmente organizados em 3 secções:

Acesso ao menu: as vistas a partir das quais o menu Arrastar & Largar está disponível são as mesmas a partir das quais o menu contextual está disponível. Consulte a página do menu contextual para mais detalhes.

Deposições possíveis e proibidas: quando é possível largar uma entidade, o cursor do rato mostra um quadrado e um sinal "mais" com ele, indicando que a entidade arrastada será copiada ou anexada à que se encontra debaixo do cursor. Quando não é possível largear, o cursor do rato transforma-se num sinal de proibição.

É proibido largear quando nenhuma acção relevante corresponde ao movimento. Por exemplo, não faz muito sentido largar uma entidade sobre si mesma, daí um sinal proibido nessa sequência.

Da mesma forma, não faz sentido largar uma entidade Família sobre uma entidade Multimédia. O inverso faz sentido e é possível.

Movimentos desactivados: quando um movimento é susceptível de criar uma grande inconsistência, o Ancestris mostra a acção como desactivada. Isto ajuda a compreender que a sua mudança foi tida em conta mas não é permitida. Por exemplo, anexar um indivíduo a um dos pais de outro numa família onde ambos os pais já estão documentados não é possível. Terá primeiro de decidir quais são os pais certos e corrigir a família antes de fazer a mudança.

Movimentos de aviso: quando um movimento é susceptível de criar uma inconsistência mas ainda é possível na prática, o Ancestris adiciona um sinal de aviso ao ícone de acção e uma dica sobre a acção, explicando o motivo do aviso. O Ancestris mostra um sinal de aviso como alerta contra potenciais erros. Por exemplo, adicionar uma dado filho a uma família quando já é filho noutra família é apenas um aviso, porque tais situações poderiam existir. Da mesma forma, uma pessoa pode ser cônjuge em várias famílias.

Acções de anexação

As acções de anexação oferecem possibilidades de anexar a entidade importada à entidade alvo.

Se as genealogias forem diferentes, a entidade importada é primeiro copiada para a genealogia de destino. Esta cópia inclui as entidades ligadas, como descrito abaixo em Acções de cópia.

Indivíduo para indivíduo

Ao anexar um indivíduo a outro, o Ancestris oferece 4 formas possíveis de o fazer:

Para cada possibilidade, o Ancestris oferece-se para utilizar uma família existente ou para criar uma nova.

Indivíduo a família ou família a indivíduo

Ao anexar um indivíduo a uma família, ou vice-versa, o Ancestris oferece 2 formas possíveis de o fazer:

Atributo a indivíduo ou família

Um atributo é uma entidade que não é uma pessoa nem uma família (e.g. uma nota, um objecto multimédia, uma fonte, um repositório ou um investigador).

Ao anexar um atributo a uma pessoa ou família, o Ancestris oferece-se para o anexar à própria entidade a um nível geral, ou então para o anexar a um dos eventos existentes dessa entidade.

Por exemplo, é possível anexar uma fonte ao evento Nascimento usando o método de Arrastar & Largar.

Atributo a atributo

Ao anexar um atributo a outro atributo, o Ancestris oferece-se para simplesmente anexar um ao outro de acordo com a conformidade Gedcom.

Por exemplo, um repositório pode ser um atributo de uma fonte, mas uma fonte não pode ser anexada a um repositório (por convenção da norma Gedcom).

Acções de cópia entre differentes genealogias

Quando as genealogias são diferentes, o Ancestris oferece 2 formas de copiar a entidade importada para a genealogia de destino:

No primeiro caso, uma família só seria copiada com os eventos, mas sem pais e filhos; um indivíduo seria copiado sem as ligações a outros indivíduos e sem as ligações a fontes ou elementos multimédia.

No segundo caso, uma família seria copiada com os pais e todos os filhos; um indivíduo seria copiado com as respectivas notas, multimédia e fontes; as fontes seriam copiadas com repositórios.

Acções de união dentro da mesma genealogia

Quando a genealogia é a mesma, o Ancestris oferece 3 formas de unir a entidade importada com a entidade destino:

Se a mesma informação única existir em ambas as entidades, tal como uma data de nascimento, a informação não é copiada no primeiro caso e é sobrescrita no segundo caso. Com o assistente, a escolha é sua.

Se a informação não for única, é adicionada no primeiro caso, ou substituída no segundo. É o caso, por exemplo, de nomes: uma pessoa pode ter mais do que um nome.

 

 

 

 

 

 

 

 

Barra de ferramentas

A barra de ferramentas da janela principal do Ancestris é uma barra horizontal que contém um certo número de ferramentas sob a forma de ícones. Situa-se entre a barra de menus e a área de trabalho.

pt_tool_bar.png

Há também barras de ferramentas para outras janelas que não a principal. Serão descritas nas secções correspondentes.

As barras de ferramentas podem igualmente ser personalizadas, pelo menos em parte. encontrará ao fundo desta página uma forma de definir a sua posição e direcção.

Ícones da barra de ferramentas

Os ícones da barra de ferramentas estão organizados por grupos. Cada grupo corresponde a uma parte das acções da barra de menus. As acções que eles realizam são descritas nos menus correspondentes.

A visibilidade de um grupo é configurável.

Grupo Ficheiro

Os ícones abaixo dizem respeito ao menu Ficheiro.

Grupo Área de transferência

Os ícones abaixo dizem respeito ao menu Editar.

Grupo Desfazer/Refazer

Os ícones abaixo dizem respeito ao menu Editar.

Grupo Desempenho

Os ícones abaixo têm funções puramente técnicas. Não estão visíveis por predefinição.

Grupo Diversos

Os ícones abaixo dizem respeito a vistas e ferramentas úteis.

Grupo Editor Aries

Os ícones abaixo permitem gerir as entidades da genealogia com o editor Aries.

Grupo Navegação

Os ícones abaixo permitem utilizar a procura geral.

Grupo Ajuda

Os ícones abaixo dizem respeito ao menu Ferramentas ou ao menu Ajuda:

 

Personalização da barra de ferramentas

A barra de ferramentas é personalizável, por exemplo, deslocando os grupos pelo "puxador" o pequeno rectângulo pontilhado à esquerda de cada grupo.

Aqui, o grupo "Diversos" está a ser movido para uma segunda linha.

pt_move_icon_group.png

De uma maneira geral, as janelas que têm barras de ferramentas podem ser personalizadas da mesma forma, o menu pode mudar de direcção, horizontal ou vertical, num dos lados da janela.

Devido ao interesse bastante limitado desta possibilidade, poucas janelas com barras de ferramentas têm esta função. Para aquelas que a têm, as barras de ferramentas em questão têm a pequena área pontilhada à sua esquerda.

Aqui está um exemplo com a barra de ferramentas do Editor Gedcom, na direcção horizontal:

pt_horizontal_tool_bar.png

pt_vertical_tool_bar_moving.png

pt_vertical_tool_bar.png

 

Barra de navegação

A barra de navegação permite avançar e recuar na lista de todas as entidades sucessivamente seleccionadas depois da abertura da última genealogia.

pt_navigation_bar.png

Descrição

A barra de navegação compreende três botões que permitem navegar na lista assim formada Estes botões estão desactivados quando a lista está vazia.

Seta à esquerda

Selecciona a entidade precedente na lista.

Seta à direita

Selecciona a entidade seguinte na lista.

Seta abaixo

Mostra a lista de todas as entidades memorizadas para selecção directa daquela que desejar.

Utilização

Desde que uma genealogia é aberta no Ancestris, a barra de navegação memoriza numa lista todas as entidades que for seleccionando sucessivamente.

É assim possível revisitar uma entidade que visitou há instantes atrás e voltar em seguida aquela onde estava a trabalhar.

A lista é multi-Gedcom: memoriza entidades de todas as genealogias abertas ao mesmo tempo numa única lista.

A lista é multi-categorias de entidades: memoriza todas as categorias de entidades numa única lista.

A lista regressa a zero quando uma genealogia é fechada.

Exemplo

A lista seguinte mostra um histórico de navegação em 10 entidades, pertencentes às genealogias dos Bourbons e à dos Kennedy.

Há indivíduos e famílias. Poderia ter ainda todos os outros tipos de entidades.