Java installatie

Ancestris heeft Java nodig en is compatible met Java 8 (ook genoemd 1.8) en Java 11. We bevelen aan dat je Java 8 gebruikt.

Als Ancestris niet wil starten, of je ziet het Ancestris fout scherm en het stopt, is dit meestal een probleem met de Java installatie. Of Java is niet geïnstalleerd, of Ancestris kan kan Java niet vinden, of het vindt een niet compatible versie, of het vindt een beschadigde Java versie.

Het volgende gedeelte biedt een stap-voor-stap controle om zeker te zijn dat Ancestris een geldige versie 8 van Java gebruikt.

Algemene principes

  • Je hebt een Java Runtime Enviiremont (JRE) nodig. De JDK (Java Development Kit) is niet vereist, maar omdat de JDK tegenwoordig ook een JRE bevat is alleen een JDK voldoende.
  • Ancestris werkt met Java versies 8 en hoger. Het is ontwikkeld in versie 8 voor een betere samenwerking met de meeste gebruikers. Het is ook getest en het werkt ook met met Java 11 en Java 14, dat zijn LTS (Long Term Support) versies. We controleren niet de Short Term versies, die eindig zijn en niet meer gedownload kunnen worden na 18 maanden.
  • Je kan een JRE ook van een andere leverancier gebruiken: Oracle, OpenJdk of AdoptOpenJdk of één die je zelf hebt samengesteld.
  • De Oracle JRE installatie wordt door alle systemen en programma's herkend.
    • Alleen de Oracle versie wordt direct herkend door de programma's en heeft geen extra installatie of configuratie nodig. 
    • Als je de Oracle versie installeert, heeft alleen JRE 8 geen Oracle  registratie nodig.
    • Op Windows, dan is er niet alleen een JAVA_HOME variabele of de PATH variabele, maar er is ook een registratie sleutel nodig.
  • Als je opteert voor een gratis installatie, zal je Ancestris moeten vertellen waar deze installatie staat. In dat geval, zoals hieronder beschreven, wis de jdkhome regel in het ancestis.conf configuratie bestand dat staat in de "etc" map van je Ancestris installatie en zet je hier het juiste pad neer.

Uitzoeken welke Java versie standaard wordt gebruikt

Als je niet weet of Java, of welke versie is geïnstalleerd, ga dan naar de  official detailed explanation page of open een commando terminal en type op de commando regel:

java -version

Er zijn verschillende methodes voor MacOS en Windows.
   - voor MacOS systemen, controleer de stap-voor-stap instructies.
   - voor Windows systemen, controleer de stap-voor-stap instructies.

  • Als je een foutboodschap krijgt te zien in het commando scherm dan is Java niet op je systeem geïnstalleerd. Ancestris start dan niet. Volg de onderstaande installeer handleiding  om Java 1.8 alsnog te installeren en Ancestris te starten.
  • Als je iets ziet wat op onderstaand lijkt waar Java 1.8 is geïnstalleerd. betekent dat er een juiste versie is geïnstalleerd en als standaard wordt gebruikt.
java version "1.8.0_251"
Java(TM) SE Runtime Environment (build 1.8.0_251-b08)
Java HotSpot(TM) 64-Bit Server VM (build 25.251-b08, mixed mode)

Zoals je in het bovenstaande scherm kan zien is dat standaard Java 1.8, aka versie 8 is geïnstalleerd. 

Als Ancestris niet wil starten dan, of Ancestris kan Java niet vinden, of vindt een niet bruikbare versie, of vindt een beschadigde versie. Volg dan de instructies om te bepalen welke versie van Java Ancestris heeft gevonden.

  • Als je een andere versie van Java vindt dan 1,8 of 11 betekent dat dat je standaard een andere versie gebruikt.
java version "10.0.1" 2018-04-17
Java(TM) SE Runtime Environment 18.3 (build 10.0.1+10)
Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.1+10, mixed mode)

Volgens bovenstaand scherm zie je dat de geïnstalleerde Java standaard versie 10 is. Ancestris zal niet starten. Ga naar de onderstaande installatie handleiding om Java 8 te installeren.

Wanneer je dit gedaan hebt zal je verschillende versies van Java op je systeem geïnstalleerd hebben.

Als je tevreden bent om Java versie 8 als standaard versie te gebruiken, volg de volgende instructies om java 8 als standaard op jouw systeem te installeren en en Ancestris te kunnen starten.

Als je echter de Java versie die je hebt wil blijven gebruiken, dan moet je Ancestris vertellen om niet de standaard versie Java te gebruiken. Volg dan de instructies om Ancestris een andere specifieke Java versie te gebruiken en dan Ancestris te starten.

Uitzoeken welke Java versie Ancestris vindt.

Als je wil weten welke versie Ancestris vindt, moet je het configuratie bestand raadplegen.(configuration file).

1. Controleer de regel default_options

De regel ziet er als volgt uit::

default_options="--branding ancestris -J-Xms96m -J-Xmx1g --laf javax.swing.plaf.nimbus.NimbusLookAndFeel"

Als één van de opties in de regel  --jdkhome="/path/to/java, bevat, wees er dan zeker van dat het pad in deze optie het pad is naar Java versie 1.8 is. Zo niet dan moet je het configuratie bestand aanpassen. Daarna start je Ancestris.

Als deze regel geen pad naar Java heeft, volg dan onderstaande instructies.

2. Controleer de regel die  jdkhome definieert.

Als de regel er uit ziet zoals jdkhome="/path/to/java", wees er dan zeker van dat het pad in deze optie het pad is naar Java versie 8. Zo niet wijzig het configuratie bestand. Start daarna Ancestris.

Als de regel start met "#", of de regel bestaat niet, betekent dat dat de regel niet gebruikt wordt door Ancestris en dat Ancestris de standaard Java versie op jouw systeem gebruikt.

Als de standaard versie hierboven Java 8 is, betekent dat misschien dat de geïnstalleerde versie Java 8 beschadigd is. Probeer dan dan Java opnieuw te installeren m.b.v. de installatie instructies en herstart dan Ancestris.

Installeer Java

Om Java versie 8 op je systeem te installeren kan je dit direct van de Oracle hoofdpagina downloaden of anders gezegd, direct van de download pagina.

  • Als je wilt weten of jouw systeem Java kan starten ga dan naar de configuratie pagina waarin staat wat de minimale configuratie is die nodig is om Java te kunnen gebruiken.
  • Als je van alle beschikbare versies van Java wil wil kiezen, ga dan naar de de beschikbare versies pagina.

Zet de standaard Java versie.

De procedure is afhankelijk van jouw systeem:

Zet de standaard versie voor MacOS.

De huidige versie van Java kan niet in overeenstemming zijn met Ancestris instellingen en zal dus niet starten.

Als je de huidige versie van Java wil bewaren en tegelijkertijd Java Version 8 (aka 1.8) ook wil blijven gebruiken zal je van versie moeten wisselen om Ancestris te kunnen gebruiken.

Om van versie te wisselen, open dan een commando scherm (terminal) en volg de onderstaande stappen.

In het volgende voorbeeld volg je de instructies om Version 8 (aka 1.8) standaard te maken zonder Java Version 10 te verwijderen:

1/6 - Controleer welke versie van java standaard is.

java -version
echo $jdkhome

Je ziet nu welke versie van Java je gebruikt.

2/6 - Je krijgt nu een overzicht welke versies op je systeem zijn geïnstalleerd en kijk of versie 8 of 11 er tussen staat.

/usr/libexec/java_home -V

Als de versie die je nodig hebt er niet bij staat, installeer deze dan met onderstaande instructies.

Als deze in de lijst staat maar niet diegene die hierboven staat, geef dan de goede pad naam op van de juiste versie met de volgende stap:

3/6 - Type de volgende 2 regels in het commando scherm

echo 'export JAVA_HOME=`/usr/libexec/java_home -v 1.8`' >>~/.bash_profile
echo 'export jdkhome==`/usr/libexec/java_home -v 1.8`' >>~/.bash_profile

Deze 2 regels voegen een commando toe om je standaard Java versie in je persoonlijk profiel te zetten. In dit voorbeeld zetten we we versie 1.8 als standaard en wordt je huidige versie daarmee vervangen.

De eerste regel definieert de standaard Java versie te gebruiken voor alle programma's (JAVA_HOME, in uppercase).

De tweede regel bepaalt de standaard Java versie te gebruiken door Ancestris (jdkhome, lowercase).

4/6 - Sluit het commando scherm (terminal)

exit

5/6 - Open opnieuw een commando scherm en controleer dat de huidige Java versie degene is die je wilt (versie 8 in dit voorbeeld)

java -version
echo $jdkhome

Je kan nu Ancestris starten.

6/6 - Start Ancestris

Wanneer Ancestris start, wordt er tegelijkertijd een commando (terminal) scherm geopend.

Je kan in de titelbalk zien dat versie 8 van Java gebruikt wordt door Ancestris.

Zet de standaard versie voor Windows

Je moet een  .BAT bestand per Java versie maken, die je wil (moet) bewaren.

Gebruik je favoriete editor om deze bestanden aan te maken. Gebruik de onderstaande code en bewaar deze bestanden in het beschikbare en juiste pad.

JAVA8.BAT

@echo off
echo Setting JAVA_HOME
set JAVA_HOME=C:\Program Files\Java\jdk1.8.0_12
echo setting PATH
set PATH=C:\Program Files\Java\jdk1.8.0_12\bin;%PATH%
echo Display java version
java -version

JAVA11.BAT

@echo off
echo Setting JAVA_HOME
set JAVA_HOME=C:\Program Files\Java\jdk1.11.0_11
echo setting PATH
set PATH=C:\Program Files\Java\jdk1.11.0_11\bin;%PATH%
echo Display java version
java -version

Wanneer je deze bestanden aanmaakt moet je opletten dat je de juiste namen gebruikt voor de Java bestanden voor de regels JAVA_HOME, afhankelijk van je Java installatie.

Wanneer je besluit om de Java versie te wijzigen, start dan het bijbehorende .BAT bestand JAVA8 voor versie 1.8, of JAVA11 voor versie 11. De Java versie die je gebruikt wordt in het commando scherm getoond.

Om te controleren of de veranderingen daadwerkelijk zijn doorgevoerd type java -version in een commando scherm of ga naar deze pagina.

Als je de laatste versie Java versie wil behouden en dat je een andere versie van Java wil gebruiken voor Ancestris, dan moet je de het configuratie bestand wijzigen, regel jdkhome="C:\path\to\java"

Zet standaard versie voor Linux

Type het volgende in een commando scherm (Console, Terminal):

sudo update-alternatives --config java

 

en_linux-java-versions.png

Selecteer uit de lijst de versie die je nodig hebt.

Als je de laatste versie Java versie wil behouden en dat je een andere versie van Java wil gebruiken voor Ancestris, dan moet je de het configuratie bestand wijzigen, regel jdkhome="/path/to/java"

Voor hulp bij het gebruik van dit gereedschap:

sudo update-alternatives -l

Stel Ancestris zo in om een specifieke Java versie te gebruiken.

Onafhankelijk van welk operating systeem je gebruikt, als de standaard actieve Java versie verschillend is van die die door Ancestris wordt gebruikt, dan moet je het configuratie bestand aanpassen zoals hieronder beschreven

jdkhome="/path/to/java"

Omgekeerd, als deze regel niet uitgezet is, d.w.z. niet met een "#" start dan zal Ancestris dit als eerste gaan zoeken. Het pad naar de Java versie moet geldig zijn en verwijzen naar een operationele versie van Java. Anders zal Ancestris niet naar een andere lokatie zoeken, voor een betere Java versie en zal Ancestris dus niet starten.

Ancestris, genealogie die met je meeleeft!

Vertaling, Ed van Driel, voorjaar 2021.

 

 


Revision #22
Created Sat, Jan 30, 2021 7:56 AM by frederic
Updated Fri, Apr 9, 2021 1:40 PM by ed